summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2017-08-26 15:12:42 +0200
committerAndy Wingo <wingo@igalia.com>2017-08-27 20:59:35 +0200
commit39c853bd61ae9744e7ad41aab620e390a04469d6 (patch)
tree8605a8fe7c9efb5df7c86378a90c6563d2116d23
parentff16170ab9e5cc565c71dc5026558c609e7a31a1 (diff)
downloadpatches-39c853bd61ae9744e7ad41aab620e390a04469d6.tar
patches-39c853bd61ae9744e7ad41aab620e390a04469d6.tar.gz
gnu: totem: Wrap environment for thumbnailer.
* gnu/packages/gnome.scm (totem): Wrap thumbnailer also in environment that sets GST_PLUGIN_SYSTEM_PATH.
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4d12ab4d59..0083cc8cab 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3646,7 +3646,9 @@ for application developers.")
(grl-plugin-path (getenv "GRL_PLUGIN_PATH")))
(wrap-program (string-append out "/bin/totem")
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
- `("GRL_PLUGIN_PATH" ":" prefix (,grl-plugin-path))))
+ `("GRL_PLUGIN_PATH" ":" prefix (,grl-plugin-path)))
+ (wrap-program (string-append out "/bin/totem-video-thumbnailer")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))
#t)))))
(home-page "https://wiki.gnome.org/Apps/Videos")
(synopsis "Simple media player for GNOME based on GStreamer")