summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:52:38 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit2cec1f6f56da12886d2c753ee96e74a50404e70a (patch)
tree8d98ad5239c3949741619994a7fb194b362e4741
parent6d45fef43ef2b5fc6e107524d0903a32dcad9999 (diff)
downloadpatches-2cec1f6f56da12886d2c753ee96e74a50404e70a.tar
patches-2cec1f6f56da12886d2c753ee96e74a50404e70a.tar.gz
gnu: Add python-oauthlib.
* gnu/packages/python.scm (python-oauthlib, python2-oauthlib): New variables.
-rw-r--r--gnu/packages/python.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3cb69d26ab..72b42e3590 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1598,3 +1598,48 @@ somewhat intelligeble.")
(define-public python2-pyjwt
(package-with-python2 python-pyjwt))
+(define-public python-oauthlib
+ (package
+ (name "python-oauthlib")
+ (version "0.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://pypi.python.org/packages/source/o/oauthlib/oauthlib-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1yaj3j64la4arwsbhbfmpnickzh3jpg9nlpyg409v8pp24isn48a"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-pyjwt" ,python-pyjwt)
+ ("python-pycrypto" ,python-pycrypto)
+ ("python-nose" ,python-nose)
+ ("python-mock" ,python-mock)))
+ (home-page "https://github.com/idan/oauthlib")
+ (synopsis "OAuth implementation for Python")
+ (description
+ "Oauthlib is a generic, spec-compliant, thorough implementation of the
+OAuth request-signing logic.")
+ (license bsd-3)))
+
+(define-public python2-oauthlib
+ (let ((base (package-with-python2 python-oauthlib)))
+ (package
+ (inherit base)
+ (name "python2-oauthlib")
+ (version "0.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://pypi.python.org/packages/source/o/oauthlib/oauthlib-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1yaj3j64la4arwsbhbfmpnickzh3jpg9nlpyg409v8pp24isn48a"))))
+ (inputs
+ (append (package-inputs base)
+ `(("python2-unittest2" ,python2-unittest2)))))))