summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-25 12:47:43 -0500
committerLeo Famulari <leo@famulari.name>2017-01-25 13:23:25 -0500
commit2663c38826cd6c2ef0c5119f8072fac8e89b2e9b (patch)
tree4df6e3e05c8684f3c4a81c7c57cece2e5eaa4677
parente9f62e527e3fdf953ff4884ed1973eec6900c8ee (diff)
downloadpatches-2663c38826cd6c2ef0c5119f8072fac8e89b2e9b.tar
patches-2663c38826cd6c2ef0c5119f8072fac8e89b2e9b.tar.gz
gnu: libxslt: Incorporate grafted patch.
* gnu/packages/xml.scm (libxslt)[replacement]: Remove field. [source]: Add patch 'libxslt-CVE-2016-4738.patch'. (libxslt/fixed): Remove variable.
-rw-r--r--gnu/packages/xml.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d16821f228..b759b33420 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -135,12 +135,12 @@ project (but it is usable outside of the Gnome platform).")
(define-public libxslt
(package
(name "libxslt")
- (replacement libxslt/fixed)
(version "1.1.29")
(source (origin
(method url-fetch)
(uri (string-append "ftp://xmlsoft.org/libxslt/libxslt-"
version ".tar.gz"))
+ (patches (search-patches "libxslt-CVE-2016-4738.patch"))
(sha256
(base32
"1klh81xbm9ppzgqk339097i39b7fnpmlj8lzn8bpczl3aww6x5xm"))
@@ -157,14 +157,6 @@ project (but it is usable outside of the Gnome platform).")
based on libxml for XML parsing, tree manipulation and XPath support.")
(license license:x11)))
-(define libxslt/fixed
- (package
- (inherit libxslt)
- (name "libxslt")
- (source (origin
- (inherit (package-source libxslt))
- (patches (search-patches "libxslt-CVE-2016-4738.patch"))))))
-
(define-public perl-graph-readwrite
(package
(name "perl-graph-readwrite")