summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-05-08 16:53:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-22 18:56:32 +0200
commit2551fee8a0255bd40b142389ae39f3ea5dd54082 (patch)
treed53dd708caf9e5640019e70b7e7fdccbfc3937e6
parente1ae3587d26336251d24bed10a9172a9d9fb2f57 (diff)
downloadpatches-2551fee8a0255bd40b142389ae39f3ea5dd54082.tar
patches-2551fee8a0255bd40b142389ae39f3ea5dd54082.tar.gz
gnu: Add sablevm-classpath.
* gnu/packages/java.scm (sablevm-classpath): New variable.
-rw-r--r--gnu/packages/java.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 6dc97fede7..18004ccf8e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -104,6 +104,45 @@ defined in The Java Language Specification into the bytecoded instruction set
and binary format defined in The Java Virtual Machine Specification.")
(license license:ibmpl1.0)))
+(define sablevm-classpath
+ (package
+ (name "sablevm-classpath")
+ (version "1.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/sablevm/sablevm/"
+ version "/sablevm-classpath-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1qyhyfz8idghxdam16hdgpa24r2x4xbg9z8c8asa3chnd79h3zw2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--with-jikes"
+ "--disable-Werror"
+ "--disable-gmp"
+ "--disable-gtk-peer"
+ "--disable-plugin"
+ "--disable-dssi"
+ "--disable-alsa"
+ "--disable-gjdoc")))
+ (inputs
+ `(("gconf" ,gconf)
+ ("gtk+" ,gtk+-2)))
+ (native-inputs
+ `(("jikes" ,jikes)
+ ("fastjar" ,fastjar)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://sablevm.org/")
+ (synopsis "Java Virtual Machine")
+ (description "SableVM is a clean-room, highly portable and efficient Java
+virtual machine. Its goals are to be reasonably small, fast, and compliant
+with the various specifications (JVM specification, JNI, invocation interface,
+etc.). SableVM is no longer maintained.
+
+This package provides the classpath library.")
+ (license license:lgpl2.1+)))
+
(define-public java-swt
(package
(name "java-swt")