summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-25 20:45:07 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:28 +0200
commit225941b02813364dcba7203d2893adc5e99e1cbc (patch)
treec3333ac48c3565b1fdf97082d41cf170e6f4c3f2
parented02e1fec882bb7fb0ce72423c42b7bd245b5ec1 (diff)
downloadpatches-225941b02813364dcba7203d2893adc5e99e1cbc.tar
patches-225941b02813364dcba7203d2893adc5e99e1cbc.tar.gz
gnu: Add prefix to license imports in (gnu packages qt).
* gnu/packages/qt.scm: Import (guix licenses) with prefix "license:".
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5a93ea22bc..95690fa962 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -20,7 +20,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages qt)
- #:use-module ((guix licenses) #:select (bsd-3 gpl2 gpl3 lgpl2.1 lgpl2.1+ lgpl3 x11-style))
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build utils)
@@ -206,7 +206,7 @@
(synopsis "Cross-platform GUI library")
(description "Qt is a cross-platform application and UI framework for
developers using C++ or QML, a CSS & JavaScript like language.")
- (license lgpl2.1)
+ (license license:lgpl2.1)
;; Qt 4: 'QBasicAtomicPointer' leads to build failures on MIPS;
;; see <http://hydra.gnu.org/build/112828>.
@@ -491,7 +491,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(synopsis "Cross-platform GUI library")
(description "Qt is a cross-platform application and UI framework for
developers using C++ or QML, a CSS & JavaScript like language.")
- (license (list lgpl2.1 lgpl3))))
+ (license (list license:lgpl2.1 license:lgpl3))))
(define-public qtsvg
(package (inherit qtbase)
@@ -920,7 +920,7 @@ is then compiled to create the bindings extension module. The SIP Python
module provides support functions to the automatically generated code.")
;; There is a choice between a python like license, gpl2 and gpl3.
;; For compatibility with pyqt, we need gpl3.
- (license gpl3)))
+ (license license:gpl3)))
(define-public python2-sip
(package (inherit python-sip)
@@ -985,7 +985,7 @@ module provides support functions to the automatically generated code.")
"PyQt is a set of Python v2 and v3 bindings for the Qt application
framework. The bindings are implemented as a set of Python modules and
contain over 620 classes.")
- (license gpl3)))
+ (license license:gpl3)))
(define-public python2-pyqt
(package (inherit python-pyqt)
@@ -1067,7 +1067,7 @@ contain over 620 classes.")
"--destdir" lib
"--sipdir" sip))))
%standard-phases)))
- (license (list gpl2 gpl3)))) ; choice of either license
+ (license (list license:gpl2 license:gpl3)))) ; choice of either license
(define-public qtkeychain
(package
@@ -1101,4 +1101,4 @@ contain over 620 classes.")
(description
"QtKeychain is a Qt library to store passwords and other secret data
securely. It will not store any data unencrypted unless explicitly requested.")
- (license bsd-3)))
+ (license license:bsd-3)))