summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-22 17:40:01 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-23 21:51:14 +0100
commit1d209d06edef7b2dfd744862add66aa3fe61f952 (patch)
treebb674859714532af8788e382be672c0b0f6c1d26
parentca53346dd57d57ba96d15a82dd9b2543723a4ad9 (diff)
downloadpatches-1d209d06edef7b2dfd744862add66aa3fe61f952.tar
patches-1d209d06edef7b2dfd744862add66aa3fe61f952.tar.gz
gnu: Add ocaml-craml.
* gnu/packages/ocaml.scm (ocaml-craml): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c62d1ee8ee..c9df31ae6a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4758,6 +4758,35 @@ speedup, polymorphic variants and optional syntax for tuples and variants.
yojson package. The program @code{atdgen} can be used to derive OCaml-JSON
serializers and deserializers from type definitions.")
(license license:bsd-3)))
+
+(define-public ocaml-craml
+ (package
+ (name "ocaml-craml")
+ (version "1.0.0")
+ (home-page "https://github.com/realworldocaml/craml")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "197xjp4vmzdymf2ndinw271ihpf45h04mx8gqj8ypspxdr5fj1a5"))))
+ (build-system dune-build-system)
+ (inputs
+ `(("ocaml-fmt" ,ocaml-fmt)
+ ("ocaml-astring" ,ocaml-astring)
+ ("ocaml-logs" ,ocaml-logs)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)))
+ (synopsis
+ "CRAM-testing framework for testing command line applications")
+ (description "CRAM is a is functional testing framework for command line
+applications. @code{craml} is freely inspired by the
+Mercurial's @code{https://www.selenic.com/blog/?p=663, unified test
+format}. @code{craml} is released as a single binary (called @code{craml}).")
+ (license license:isc)))
(define-public ocaml-merlin
(package