summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-16 16:55:18 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-19 08:44:11 +0200
commit1bd00f1737021370a031db43f890b4ae57aa2d13 (patch)
treee74301e5c22da32d15e87d4d0728ebe7b748b0d1
parentdb61a00971fbc4f197dd147419fa66212169e4b4 (diff)
downloadpatches-1bd00f1737021370a031db43f890b4ae57aa2d13.tar
patches-1bd00f1737021370a031db43f890b4ae57aa2d13.tar.gz
gnu: Add ghc-hashtables.
* gnu/packages/haskell.scm (ghc-hashtables): New variable.
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8d8330805e..ae8d6e677a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7749,4 +7749,29 @@ interface for statistics based on hmatrix and GSL.")
Haskell, using gnuplot for rendering.")
(license license:expat)))
+(define-public ghc-hashtables
+ (package
+ (name "ghc-hashtables")
+ (version "1.2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/hashtables/hashtables-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1b6w9xznk42732vpd8ili60k12yq190xnajgga0iwbdpyg424lgg"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hashable" ,ghc-hashable)
+ ("ghc-primitive" ,ghc-primitive)
+ ("ghc-vector" ,ghc-vector)))
+ (home-page "http://github.com/gregorycollins/hashtables")
+ (synopsis "Haskell Mutable hash tables in the ST monad")
+ (description "This package provides a Haskell library including a
+couple of different implementations of mutable hash tables in the ST
+monad, as well as a typeclass abstracting their common operations, and
+a set of wrappers to use the hash tables in the IO monad.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here