summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-03-20 21:11:04 +0000
committerChristopher Baines <mail@cbaines.net>2020-03-26 22:51:36 +0000
commit0a76a4e0733741f3140fc394e98fed4febdbebca (patch)
tree545ca200cc822f6399801d250a323081f2c34b3e
parent01d5f2c5cd68037666405af00d62bd677d5fd015 (diff)
downloadpatches-0a76a4e0733741f3140fc394e98fed4febdbebca.tar
patches-0a76a4e0733741f3140fc394e98fed4febdbebca.tar.gz
gnu: guix-data-service: Update to 0.0.1-19.d1c243f.base-for-series-3304
These changes support the guix-data-service-backup-database and guix-data-service-create-small-backup scripts. These are shell scripts, so require coreutils from the build environment at runtime as well as binaries from postgresql, ephemeralpg and optionally util-linux (for ionice and renice). * gnu/packages/web.scm (guix-data-service): Update to 0.0.1-19.d1c243f. [arguments]: Add (ice-9 ftw) and (ice-9 match) to #:modules, change the 'install phase to wrap all bin files with some inputs as well. [inputs]: Add util-linux, include ephemeralpg from native-inputs and switch postgresql for postgresql-11. [native-inputs]: Move ephemeralpg to inputs.
-rw-r--r--gnu/packages/web.scm37
1 files changed, 24 insertions, 13 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6ce8b78c85..a553dc2150 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4382,8 +4382,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "18eb9dfdcb3174bfd4bab5b9089acffa13aa1214")
- (revision "18"))
+ (let ((commit "d1c243f7fd8902f359ff06fb78dce663cf4297ce")
+ (revision "19"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4395,11 +4395,13 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(file-name (git-file-name name version))
(sha256
(base32
- "0lb78cqzqaz0r4sspg272w2a3yhzhqah30j0kxf0z182b0qpmp37"))))
+ "1ji8d4vwmv7j9h7z96hvzi3zvik594yngjrdal37w13fbxy2v6sw"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
(guix build gnu-build-system)
+ (ice-9 ftw)
+ (ice-9 match)
(ice-9 rdelim)
(ice-9 popen))
#:test-target "check-with-tmp-database"
@@ -4427,20 +4429,28 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
"/site-ccache")))
(for-each
(lambda (file)
+ (simple-format (current-error-port)
+ "wrapping: ~A\n"
+ (string-append bin "/" file))
(wrap-program (string-append bin "/" file)
`("PATH" ":" prefix
- (,bin))
+ ,(cons*
+ bin
+ (map (lambda (input)
+ (string-append
+ (assoc-ref inputs input)
+ "/bin"))
+ '("ephemeralpg"
+ "util-linux"
+ "postgresql"))))
`("GUILE_LOAD_PATH" ":" prefix
(,scm ,(getenv "GUILE_LOAD_PATH")))
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
(,go ,(getenv "GUILE_LOAD_COMPILED_PATH")))))
- '("guix-data-service"
- "guix-data-service-process-branch-updated-email"
- "guix-data-service-process-branch-updated-mbox"
- "guix-data-service-process-job"
- "guix-data-service-process-jobs"
- "guix-data-service-manage-build-servers"
- "guix-data-service-query-build-servers"))
+ (scandir bin
+ (match-lambda
+ ((or "." "..") #f)
+ (_ #t))))
#t)))
(delete 'strip)))) ; As the .go files aren't compatible
(inputs
@@ -4449,13 +4459,14 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
("guile-json" ,guile3.0-json)
("guile-email" ,guile3.0-email)
("guile-squee" ,guile3.0-squee)
- ("postgresql" ,postgresql)
+ ("ephemeralpg" ,ephemeralpg)
+ ("util-linux" ,util-linux)
+ ("postgresql" ,postgresql-11)
("sqitch" ,sqitch)))
(native-inputs
`(("guile" ,guile-3.0)
("autoconf" ,autoconf)
("automake" ,automake)
- ("ephemeralpg" ,ephemeralpg)
("emacs-minimal" ,emacs-minimal)
("emacs-htmlize" ,emacs-htmlize)
("pkg-config" ,pkg-config)))