summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:30:31 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit070ab0588c163151727c6de272c8b9cdf5827469 (patch)
tree219de64063f0d24b61460c8a37b43a6fdd05e0dd
parentdac79ecc513099662c9e4b3219b77ee46e900521 (diff)
downloadpatches-070ab0588c163151727c6de272c8b9cdf5827469.tar
patches-070ab0588c163151727c6de272c8b9cdf5827469.tar.gz
gnu: Add python-subunit.
* gnu/packages/python.scm (python-subunit, python2-subunit): New variables.
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 40d979009d..914330edcf 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1239,6 +1239,35 @@ use of resources by test cases.")
(define-public python2-testresources
(package-with-python2 python-testresources))
+(define-public python-subunit
+ (package
+ (name "python-subunit")
+ (version "0.0.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/python-subunit/python-subunit-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1nkw9wfbvizmpajbj3in8ns07g7lwkiv8hip14jjlwk3cacls6jv"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-testtools" ,python-testtools)
+ ("python-mimeparse" ,python-mimeparse)
+ ("python-testscenarios" ,python-testscenarios)))
+ (home-page "http://launchpad.net/subunit")
+ (synopsis "Python implementation of the subunit protocol")
+ (description
+ "Python-subunit is a Python implementation of the subunit test streaming
+protocol.")
+ (license (list bsd-3 asl2.0)))) ; at the user's option
+
+(define-public python2-subunit
+ (package-with-python2 python-subunit))
+
(define-public behave
(package
(name "behave")