summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-04-15 18:43:55 +0100
committerChristopher Baines <mail@cbaines.net>2020-05-26 09:02:05 +0100
commit06fe35cf0c27545e8d995aaf35b7b11987f4ed67 (patch)
tree16e405da4753ae2841cdec4d21a1c33412d34ae9
parent5d31933e0b8520ee831e71dcd0ede6ec3de5216e (diff)
downloadpatches-06fe35cf0c27545e8d995aaf35b7b11987f4ed67.tar
patches-06fe35cf0c27545e8d995aaf35b7b11987f4ed67.tar.gz
gnu: python-pyatspi: Propagate python-pygobject.
As python-pygobject is required at runtime. * gnu/packages/gnome.scm (python-pyatspi)[inputs]: Move python-pygobject to… [propagated-inputs]: …here. (python2-pyatspi)[inputs]: Move python2-pygobject to… [propagated-inputs]: …here.
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fdbec60881..94a649779e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8849,8 +8849,9 @@ from gi.repository import Atspi"))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("python" ,python)
- ("python-pygobject" ,python-pygobject)))
+ `(("python" ,python)))
+ (propagated-inputs
+ `(("python-pygobject" ,python-pygobject)))
(synopsis "Python client bindings for D-Bus AT-SPI")
(home-page "https://wiki.linuxfoundation.org/accessibility\
/atk/at-spi/at-spi_on_d-bus")
@@ -8865,8 +8866,9 @@ accessibility infrastructure.")
(inherit python-pyatspi)
(name "python2-pyatspi")
(inputs
- `(("python" ,python-2)
- ("python-pygobject" ,python2-pygobject)))))
+ `(("python" ,python-2)))
+ (propagated-inputs
+ `(("python-pygobject" ,python2-pygobject)))))
(define-public orca
(package