summaryrefslogtreecommitdiff
path: root/.dir-locals.el
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-03 22:45:25 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-03 23:12:20 +0200
commitb860f382447a360ea2ce8a89d3357279cc652c3a (patch)
treed897f612bde6d3e3a4b78af7cab3a357d4748539 /.dir-locals.el
parentc8957c77d65bdb6c0bd9afb009f79279ffc6e129 (diff)
downloadpatches-b860f382447a360ea2ce8a89d3357279cc652c3a.tar
patches-b860f382447a360ea2ce8a89d3357279cc652c3a.tar.gz
Add (guix monads).
* guix/monads.scm: New file. * tests/monads.scm: New file. * Makefile.am (MODULES): Add guix/monads.scm. (SCM_TESTS): Add tests/monads.scm. * doc/guix.texi (The Store Monad): New node. (The Store): Reference it.
Diffstat (limited to '.dir-locals.el')
-rw-r--r--.dir-locals.el8
1 files changed, 7 insertions, 1 deletions
diff --git a/.dir-locals.el b/.dir-locals.el
index fc41d430b4..b55ec7590e 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -16,7 +16,13 @@
(eval . (put 'package 'scheme-indent-function 1))
(eval . (put 'substitute-keyword-arguments 'scheme-indent-function 1))
(eval . (put 'with-error-handling 'scheme-indent-function 0))
- (eval . (put 'with-mutex 'scheme-indent-function 1))))
+ (eval . (put 'with-mutex 'scheme-indent-function 1))
+
+ (eval . (put 'syntax-parameterize 'scheme-indent-function 1))
+ (eval . (put 'with-monad 'scheme-indent-function 1))
+ (eval . (put 'mlet* 'scheme-indent-function 2))
+ (eval . (put 'mlet 'scheme-indent-function 2))
+ (eval . (put 'run-with-store 'scheme-indent-function 1))))
(emacs-lisp-mode . ((indent-tabs-mode . nil)))
(texinfo-mode . ((indent-tabs-mode . nil)
(fill-column . 72))))