summaryrefslogtreecommitdiff
path: root/.dir-locals.el
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-28 23:00:57 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-28 23:24:17 +0200
commit21b679f6944f4e1f09f949322f5242b761dc22a7 (patch)
tree501a32d37b7765db7e7a8c046fcd99ae40ed4877 /.dir-locals.el
parentba948b4fa0a088f42815aa104e651c9d14d8a1ba (diff)
downloadpatches-21b679f6944f4e1f09f949322f5242b761dc22a7.tar
patches-21b679f6944f4e1f09f949322f5242b761dc22a7.tar.gz
Add (guix gexp).
* guix/gexp.scm: New file. * tests/gexp.scm: New file. * Makefile.am (MODULES): Add guix/gexp.scm. (SCM_TESTS): Add tests/gexp.scm. * doc/guix.texi (Derivations): Add #:inputs in 'derivation' example. Mark 'build-expression->derivation' as deprecated, refer to "G-Expressions". Remove paragraph about code strata. (G-Expressions): New node.
Diffstat (limited to '.dir-locals.el')
-rw-r--r--.dir-locals.el9
1 files changed, 8 insertions, 1 deletions
diff --git a/.dir-locals.el b/.dir-locals.el
index 49380fe4ba..a6135b171e 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -6,6 +6,7 @@
(scheme-mode
.
((indent-tabs-mode . nil)
+ (eval . (put 'eval-when 'scheme-indent-function 1))
(eval . (put 'test-assert 'scheme-indent-function 1))
(eval . (put 'test-equal 'scheme-indent-function 1))
(eval . (put 'test-eq 'scheme-indent-function 1))
@@ -31,7 +32,13 @@
(eval . (put 'with-monad 'scheme-indent-function 1))
(eval . (put 'mlet* 'scheme-indent-function 2))
(eval . (put 'mlet 'scheme-indent-function 2))
- (eval . (put 'run-with-store 'scheme-indent-function 1))))
+ (eval . (put 'run-with-store 'scheme-indent-function 1))
+
+ ;; Recognize '~' and '$', as used for gexps, as quotation symbols. This
+ ;; notably allows '(' in Paredit to not insert a space when the preceding
+ ;; symbol is one of these.
+ (eval . (modify-syntax-entry ?~ "'"))
+ (eval . (modify-syntax-entry ?$ "'"))))
(emacs-lisp-mode . ((indent-tabs-mode . nil)))
(texinfo-mode . ((indent-tabs-mode . nil)
(fill-column . 72))))