From e9d0ebe446c1076a6196b7bb125a4ba02faa10eb Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sun, 3 Oct 2021 15:21:00 +0300
Subject: gnu: python-gnupg: Honor #:tests? flag.

* gnu/packages/gnupg.scm (python-gnupg)[arguments]: Adjust custom 'check
phase to honor the #:tests? flag.
---
 gnu/packages/gnupg.scm | 21 +++++++++++----------
 1 file changed, 11 insertions(+), 10 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 40f9ce3d81..8c8f491a18 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -583,16 +583,17 @@ (define-public python-gnupg
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (substitute* "test_gnupg.py"
-               ;; Unsure why this test fails.
-               (("'test_search_keys'") "True")
-               (("def test_search_keys") "def disabled__search_keys"))
-             (setenv "USERNAME" "guixbuilder")
-             ;; The doctests are extremely slow and sometimes time out,
-             ;; so we disable them.
-             (invoke "python"
-                     "test_gnupg.py" "--no-doctests"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (substitute* "test_gnupg.py"
+                 ;; Unsure why this test fails.
+                 (("'test_search_keys'") "True")
+                 (("def test_search_keys") "def disabled__search_keys"))
+               (setenv "USERNAME" "guixbuilder")
+               ;; The doctests are extremely slow and sometimes time out,
+               ;; so we disable them.
+               (invoke "python"
+                       "test_gnupg.py" "--no-doctests")))))))
     (native-inputs
      `(("gnupg" ,gnupg)))
     (home-page "https://pythonhosted.org/python-gnupg/index.html")
-- 
cgit v1.2.3