From b8175e3aa287c3ff239f3c7ae8fb606f7a900d06 Mon Sep 17 00:00:00 2001
From: Vinicius Monego <monego@posteo.net>
Date: Sun, 19 Dec 2021 00:29:16 +0000
Subject: gnu: Remove python2-amqp.

* gnu/packages/python-xyz.scm (python2-amqp): Remove variable.
(python-amqp)[properties]: Remove.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
---
 gnu/packages/python-xyz.scm | 13 +------------
 1 file changed, 1 insertion(+), 12 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 348dd992ed..f2479f64dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13952,18 +13952,7 @@ and provides a uniform API regardless of which JSON implementation is used.")
      "This is a fork of amqplib which was originally written by Barry Pederson.
 It is maintained by the Celery project, and used by kombu as a pure python
 alternative when librabbitmq is not available.")
-    (license license:lgpl2.1+)
-    (properties `((python2-variant . ,(delay python2-amqp))))))
-
-(define-public python2-amqp
-  (let ((amqp (package-with-python2
-               (strip-python2-variant python-amqp))))
-    (package/inherit amqp
-      (arguments `(;; Tries to run coverage tests with nose-cover3, which seems
-                   ;; unmaintained.  Weirdly, does not do this on the python 3
-                   ;; version?
-                   #:tests? #f
-                   ,@(package-arguments amqp))))))
+    (license license:lgpl2.1+)))
 
 (define-public python-txamqp
   (package
-- 
cgit v1.2.3