From ad66469b240cdf487b6deddff145ccc7091ca529 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Mon, 27 Feb 2023 17:30:30 -0500
Subject: gnu: Fix kernel source infodoc patching for linux-libre >= 6.2.

* gnu/packages/linux.scm (doc-supported?): Rename to ...
(apply-infodoc-patch?): ... new variable with different kernel version
constraints.
(make-linux-libre): Adjust accordingly.
---
 gnu/packages/linux.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 747e414e6d..e3acaeb60b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -863,10 +863,12 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
 ;;; Kernel package utilities.
 ;;;
 
-(define (doc-supported? version)
+(define (apply-infodoc-patch? version)
   ;; Versions older than 5.10 have different enough build scripts that the
   ;; infodocs patch doesn't apply.
-  (version>=? version "5.10"))
+  (and (version>=? version "5.10")
+       (not (version>=? version "6.2")))) ;patch applied upstream
+
 
 (define* (make-linux-libre version gnu-revision hash-string supported-systems
                            #:key
@@ -879,7 +881,7 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
                            (extra-options %default-extra-linux-options)
                            (patches
                             `(,%boot-logo-patch
-                              ,@(if (doc-supported? version)
+                              ,@(if (apply-infodoc-patch? version)
                                     (list (search-patch
                                            "linux-libre-infodocs-target.patch"))
                                     '()))))
-- 
cgit v1.2.3