From 669be6acfe119a6a9fef4d97a0c14d4adb67dca5 Mon Sep 17 00:00:00 2001
From: Oleg Pykhalov <go.wigust@gmail.com>
Date: Fri, 17 Nov 2017 04:08:33 +0300
Subject: gnu: cool-retro-term: Fix qml path.

* gnu/packages/terminals.scm (cool-retro-term): Fix qml path.
---
 gnu/packages/terminals.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 2f74c5d5b5..215511864a 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -493,7 +493,7 @@ embedded kernel situations.")
                       (share (string-append out "/share")))
                  (substitute* '("qmltermwidget/qmltermwidget.pro")
                    (("INSTALL_DIR = \\$\\$\\[QT_INSTALL_QML\\]")
-                    (string-append "INSTALL_DIR = " out "/qml")))
+                    (string-append "INSTALL_DIR = " out "/lib/qt5/qml")))
                  (substitute* '("app/app.pro")
                    (("target.path \\+= /usr")
                     (string-append "target.path += " out))
@@ -514,7 +514,7 @@ embedded kernel situations.")
            (add-after 'install 'wrap-executable
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))
-                      (qml "/qml"))
+                      (qml "/lib/qt5/qml"))
                  (wrap-program (string-append out "/bin/cool-retro-term")
                    `("QML2_IMPORT_PATH" ":" prefix
                      (,(string-append out qml)
-- 
cgit v1.2.3