From 63c0c19a64773da0bbbd54b5bd07b9240246eb68 Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludo@gnu.org>
Date: Sat, 1 Jun 2013 00:07:26 +0200
Subject: gnu: gawk: Refer to the target Bash in io.c.

* gnu/packages/gawk.scm (gawk): Add Bash as an input
  when (%current-target-system) is true.
---
 gnu/packages/gawk.scm | 21 ++++++++++++---------
 1 file changed, 12 insertions(+), 9 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 34a119f05b..444fa5e556 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -18,6 +18,7 @@
 
 (define-module (gnu packages gawk)
   #:use-module (guix licenses)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages libsigsegv)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -45,18 +46,20 @@
                 (lambda* (#:key inputs #:allow-other-keys)
                   ;; Refer to the right shell.
                   ;; FIXME: Remove `else' arm upon core-updates.
-                  ,(if (%current-target-system)
-                       '(let ((sh (which "sh")))
-                          (substitute* "io.c"
-                            (("/bin/sh") sh)))
-                       '(let ((bash (assoc-ref inputs "bash")))
-                          (substitute* "io.c"
-                            (("/bin/sh")
-                             (string-append bash "/bin/bash"))))))
+                  (let ((bash (assoc-ref inputs "bash")))
+                    (substitute* "io.c"
+                      (("/bin/sh")
+                       (string-append bash "/bin/bash")))))
                 ,(if (%current-target-system)
                      '%standard-cross-phases
                      '%standard-phases))))
-   (inputs `(("libsigsegv" ,libsigsegv)))
+   (inputs `(("libsigsegv" ,libsigsegv)
+
+             ;; TODO: On next core-updates, make Bash input unconditional.
+             ,@(if (%current-target-system)
+                   `(("bash" ,bash))
+                   '())))
+
    (home-page "http://www.gnu.org/software/gawk/")
    (synopsis "A text scanning and processing language")
    (description
-- 
cgit v1.2.3