From 5bf37e9c38d7804136fb91075581aac77c86bd87 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Sat, 9 Jun 2018 12:25:32 +0100
Subject: gnu: openttd: Add patch to fix compilation.

* gnu/packages/games.scm (openttd)[source]: Add a unreleased upstream patch to
fix building OpenTTD with ICU 61.
---
 gnu/packages/games.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

(limited to 'gnu')

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5568de033b..c445154b69 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2001,6 +2001,16 @@ (define openttd-engine
      (origin (method url-fetch)
              (uri (string-append "http://binaries.openttd.org/releases/"
                                  version "/openttd-" version "-source.tar.xz"))
+             (patches
+              (list
+               (origin (method url-fetch)
+                       (uri (string-append
+                             "https://github.com/OpenTTD/OpenTTD/commit/"
+                             "19076c24c1f3baf2a22d1fa832d5688216cf54a3.patch"))
+                       (file-name "openttd-fix-compilation-with-ICU-61.patch")
+                       (sha256
+                        (base32
+                         "02d1xmb75yv4x6rfnvxk3vvq4l3lvvwr2pfsdzn7lzalic51ziqh")))))
              (sha256
               (base32
                "0dhv5bbbg1dmmq7fi3xss0a9jq2rqgb5sf9fsqzlsjcdm590j6b1"))
-- 
cgit v1.2.3