From 186d4f8d08b8c25ceddcc1caf03a9cf1323110db Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 22 Apr 2017 13:34:24 +0200
Subject: gnu: Add python-diff-match-patch.

* gnu/packages/python.scm (python-diff-match-patch, python2-diff-match-patch):
New variables.
---
 gnu/packages/python.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

(limited to 'gnu')

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 13eeefed1e..d6470dbe92 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14282,3 +14282,24 @@ (define-public python-cssmin
 
 (define-public python2-cssmin
   (package-with-python2 python-cssmin))
+
+(define-public python-diff-match-patch
+  (package
+    (name "python-diff-match-patch")
+    (version "20121119")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "diff-match-patch" version))
+        (sha256
+         (base32
+          "0k1f3v8nbidcmmrk65m7h8v41jqi37653za9fcs96y7jzc8mdflx"))))
+    (build-system python-build-system)
+    (home-page "https://code.google.com/p/google-diff-match-patch")
+    (synopsis "Synchronize plain text")
+    (description "Diff Match and Patch libraries offer robust algorithms to
+perform the operations required for synchronizing plain text.")
+    (license license:asl2.0)))
+
+(define-public python2-diff-match-patch
+  (package-with-python2 python-diff-match-patch))
-- 
cgit v1.2.3