From e87845ee2dfd5c7ef5be7acf96813987900986e6 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 19 Nov 2023 01:00:00 +0100
Subject: gnu: turbostat: Use G-expressions.

* gnu/packages/linux.scm (turbostat)[arguments]:
Rewrite as G-expressions.

Change-Id: I5e2cf484692cda608d0144f4b35c63770301aadd
---
 gnu/packages/linux.scm | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c4f005ea67..4df8135a78 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6618,17 +6618,17 @@ by hand is no trivial task: @command{tmon} aims to make it understandable.")
     (source (package-source linux-libre))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; no test suite
-       #:make-flags
-       (list (string-append "CC=" ,(cc-for-target))
-             (string-append "PREFIX=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'enter-subdirectory
-           (lambda _
-             (chdir "tools/power/x86/turbostat")
-             #t))
-         (delete 'configure))))         ; no configure script
+     (list
+      #:tests? #f                       ;no test suite
+      #:make-flags
+      #~(list (string-append "CC=" #$(cc-for-target))
+              (string-append "PREFIX=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'enter-subdirectory
+            (lambda _
+              (chdir "tools/power/x86/turbostat")))
+          (delete 'configure))))         ;no configure script
     (inputs
      (list libcap))
     (supported-systems '("i686-linux" "x86_64-linux"))
-- 
cgit v1.2.3