From ca82bdfdfbb6d2dae5875158ed418cc823bc5799 Mon Sep 17 00:00:00 2001
From: Oleg Pykhalov <go.wigust@gmail.com>
Date: Fri, 8 Jun 2018 19:11:24 +0300
Subject: gnu: twitchy: Install 'rofi-twitchy'.

* gnu/packages/video.scm (twitchy): Install 'rofi-twitchy'.
---
 gnu/packages/video.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 51ca1c0ce5..8cd7a3d57c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1865,7 +1865,12 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
            (add-before 'check 'check-setup
              (lambda _
                (setenv "HOME" (getcwd)) ;Needs to write to ‘$HOME’.
-               #t)))))
+               #t))
+           (add-after 'install 'install-rofi-plugin
+             (lambda* (#:key outputs #:allow-other-keys)
+               (install-file "plugins/rofi-twitchy"
+                             (string-append (assoc-ref outputs "out")
+                                            "/bin")))))))
       (inputs
        `(("python-requests" ,python-requests)
          ("streamlink" ,streamlink)))
-- 
cgit v1.2.3