From 4a9c4dbe3beea4cb9809cdf2ce6105143f705ac9 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Wed, 11 Oct 2017 00:58:57 -0400
Subject: gnu: Add go-github-com-minio-sha256-simd.

* gnu/packages/syncthing.scm (go-github-com-minio-sha256-simd): New variable.
---
 gnu/packages/syncthing.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

(limited to 'gnu/packages')

diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 0325a0f595..1a14fa90a7 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -383,3 +383,28 @@ finding resources located relative to the executable file.")
 database/sql package.")
       (home-page "https://github.com/lib/pq")
       (license expat))))
+
+(define-public go-github-com-minio-sha256-simd
+  (let ((commit "6124d070eb4e7001c244b6ccc282620a5dce44a0")
+        (revision "0"))
+    (package
+      (name "go-github-com-minio-sha256-simd")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/minio/sha256-simd")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1azrdp7x7vl9ngkxs890blspz0345xhadvssdlb0435hdqa0gkll"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/minio/sha256-simd"))
+      (synopsis "Hardware-accelerated SHA256 in Go using SIMD")
+      (description "This packages provides a pure Go implementation of SHA256
+using SIMD (Single instruction, multiple data) instructions for Intel and ARM
+architectures.")
+      (home-page "https://github.com/minio/sha256-simd")
+      (license asl2.0))))
-- 
cgit v1.2.3