From 43e8824d3cd3ff53671167ab9b41f0094458a4d6 Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Sun, 4 Dec 2016 23:13:26 +0100
Subject: gnu: python-pyqt: Fix build by explicitly setting the stubsdir.

* gnu/packages.qt.scm (python-pyqt, python2-pyqt)[arguments]: In phase
'configure' pass option --stubsdir.
---
 gnu/packages/qt.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index aaa7e1cff7..4a8fb6c66d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1015,13 +1015,19 @@ module provides support functions to the automatically generated code.")
                         "."))
                     (lib (string-append out "/lib/python"
                                         python-major+minor
-                                        "/site-packages")))
+                                        "/site-packages"))
+                    (stubs (string-append lib "/PyQt5")))
                (zero? (system* "python" "configure.py"
                                "--confirm-license"
                                "--bindir" bin
                                "--destdir" lib
                                "--designer-plugindir" designer
                                "--qml-plugindir" qml
+                               ; Where to install the PEP 484 Type Hints stub
+                               ; files. Without this the stubs are tried to be
+                               ; installed into the python package's
+                               ; site-package directory, which is read-only.
+                               "--stubsdir" stubs
                                "--sipdir" sip))))))))
     (home-page "https://www.riverbankcomputing.com/software/pyqt/intro")
     (synopsis "Python bindings for Qt")
-- 
cgit v1.2.3