From 2529c8381f622b78b02e53a4e95dd6ad65b1f8e4 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sat, 10 Nov 2018 19:57:26 +0200
Subject: gnu: dvd+rw-tools: Fix building with glibc@2.28.

* gnu/packages/cdrom.scm (dvd+rw-tools)[arguments]: Add custom phase to
add missing import.
---
 gnu/packages/cdrom.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

(limited to 'gnu/packages')

diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index d8dc9ee6f9..992c204d2f 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -291,6 +291,15 @@ (define-public dvd+rw-tools
      `(#:tests? #f ; No tests.
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-glibc-compatability
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; We use sed --in-place because substitute* cannot handle the
+             ;; character encoding used by growisofs.c.
+             (invoke "sed" "-i" "-e"
+                     (string-append
+                       "s,<sys/stat.h>,"
+                       "<sys/stat.h>\\\n#include <sys/sysmacros.h>,")
+                     "growisofs.c")))
          (replace 'configure
            (lambda _ (setenv "prefix" (assoc-ref %outputs "out")) #t))
          (add-before 'build 'embed-mkisofs
-- 
cgit v1.2.3