From f3b98f4fec43c951a9e28c67561395992bf190a7 Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Wed, 28 Sep 2016 13:30:54 +0200
Subject: gnu: Remove python-setuptools and python2-setuptools from inputs
 (part 2)

This patch contains the changes where removing setuptools from the inputs
affected some code-lines beside.

* gnu/packages/admin.scm (ansible): Remove all [inputs], [native-inputs] and
  [propagated-inputs] where python-setuptools or python2-setuptools are the
  sole entries. Remove python-setuptools and python2-setuptools listed on a
  line by its own from [inputs], [native-inputs] and [propagated-inputs].

* gnu/packages/backup.scm (duplicity): Likewise.
* gnu/packages/bioinformatics.scm (bamm, python2-pybedtools,
  python2-bx-python, python2-dendropy, python-pysam, python2-pysam, clipper,
  crossmap, cutadapt, deeptools, grit, idr, python2-warpedlmm,
  pbtranscript-tofu, seqmagick): Likewise.
* gnu/packages/docbook.scm (dblatex): Likewise.
* gnu/packages/freedesktop.scm (python-pyxdg, python2-pyxdg): Likewise.
* gnu/packages/lirc.scm (python2-lirc): Likewise.
* gnu/packages/mp3.scm (eyed3): Likewise.
* gnu/packages/nutrition.scm (gourmet): Likewise.
* gnu/packages/openstack.scm (python-hacking, python2-hacking,
  python-os-testr, python2-os-testr,
  python-stevedore, python2-stevedore,
  python-tempest-lib, python2-tempest-lib,
  python-oslo.log, python2-oslo.log,
  python-keystoneclient, python2-keystoneclient): Likewise.
* gnu/packages/password-utils.scm (assword): Likewise.
* gnu/packages/python.scm (python-passlib, python2-passlib,
  python-babel, python2-babel,
  python-parse-type,
  python-pytest, python2-pytest,
  python-scripttest, python2-scripttest,
  python-testtools, python2-testtools,
  python-testscenarios, python2-testscenarios,
  python-subunit, python2-subunit,
  python-pbr-0.11,
  python-pbr, python2-pbr,
  python-testrepository, python2-testrepository,
  behave,
  python-wheel, python2-wheel,
  python-requests, python2-requests,
  python-jsonschema, python2-jsonschema,
  python-pyjwt, python2-pyjwt,
  python-virtualenv, python2-virtualenv,
  python-jinja2, python2-jinja2,
  python-joblib, python2-joblib,
  python-sphinx, python2-sphinx,
  python-feedgenerator, python2-feedgenerator,
  python-scikit-image, python2-scikit-image,
  python-redis, python2-redis,
  python2-fastlmm,
  python-numpydoc, python2-numpydoc,
  python-matplotlib, python2-matplotlib,
  python2-pysnptools,
  python-rpy2, python2-rpy2,
  python-pillow, python2-pillow,
  python-pycparser, python2-pycparser,
  python-cffi, python2-cffi,
  python-cairocffi, python2-cairocffi,
  python-drmaa, python2-drmaa,
  python-pathpy, python2-pathpy,
  python-simplegeneric, python2-simplegeneric,
  python-ipython, python2-ipython,
  python-apsw, python2-apsw,
  python-lxml, python2-lxml,
  python-networkx, python2-networkx,
  python-pyzmq, python2-pyzmq,
  python-mccabe, python2-mccabe,
  python-mccabe-0.2.1,
  python-flake8, python2-flake8,
  python-flake8-2.2.4,
  python-mistune, python2-mistune,
  python-ptyprocess, python2-ptyprocess,
  python-llfuse, python2-llfuse,
  python-webob, python2-webob,
  python-xlrd, python2-xlrd,
  python-tables, python2-tables,
  python-pip, python2-pip,
  python-libarchive-c, python2-libarchive-c,
  python-docopt, python2-docopt,
  python-pyrfc3339, python2-pyrfc3339,
  python-configobj, python2-configobj,
  python-clint, python2-clint,
  python-rply, python2-rply,
  python2-rpython,
  python-widgetsnbextension, python2-widgetsnbextension
  jupyter,
  python-jupyter-console, python2-jupyter-console,
  python-hy, python2-hy,
  python-urllib3, python2-urllib3,
  python-rsa, python2-rsa,
  python-tox, python2-tox,
  python2-hypothesis,
  python-paste, python2-paste,
  python-pastescript, python2-pastescript,
  python2-unicodecsv,
  python-pkgconfig, python2-pkgconfig,
  python2-rope,
  python-sqlparse, python2-sqlparse,
  python-gevent, python2-gevent,
  python-tabulate, python2-tabulate,
  python-arrow, python2-arrow,
  python-cleo, python2-cleo,
  python-fake-factory, python2-fake-factory,
  ptpython): Likewise.
* gnu/packages/rdf.scm (python-rdflib, python2-rdflib): Likewise.
* gnu/packages/terminals.scm (asciinema): Likewise.
* gnu/packages/version-control.scm (git-annex-remote-hubic): Likewise.
* gnu/packages/xdisorg.scm (arandr): Likewise.
---
 gnu/packages/rdf.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

(limited to 'gnu/packages/rdf.scm')

diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index d0a362c3a0..1a8d13369b 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -318,8 +318,7 @@ (define-public python-rdflib
     (inputs
       `(("python-html5lib" ,python-html5lib)
         ("python-isodate" ,python-isodate)
-        ("python-pyparsing" ,python-pyparsing)
-        ("python-setuptools" ,python-setuptools)))
+        ("python-pyparsing" ,python-pyparsing)))
     (home-page "https://github.com/RDFLib/rdflib")
     (synopsis
       "Python RDF library")
-- 
cgit v1.2.3


From f22efa0152356da4755241de3726b6a254b49d11 Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Thu, 13 Oct 2016 13:33:43 +0200
Subject: gnu: Fix python inputs, part 1: all inputs become propagated-inputs.

This patch contains the changes where all [inputs] are changed to
[propagated-inputs]

* gnu/packages/python.scm (python-passlib, python-paramiko, python-ccm,
  python-babel, python-keyring python-pandas, python-tzlocal,
  python-parse-type, python-nose2, python-pytest, python-pytest-mock,
  python-pytest-xdist, python-scripttest, python-testtools, python-pytest-cov,
  python-testscenarios, python-pbr-0.11, python-oauthlib, python-jinja2,
  python-sphinx, python-tzlocal, python-bugz, python2-pytest-mock, behave,
  pelican, sqlalchemy-utils, python-pygridtools, python-urwidtrees,
  python-tornado, python2-tornado, python-debian, python-execnet,
  python-pytest-cache, pytest-localserver, python-clint, python-rply,
  python-hy, python-rauth, python-rsa, python-celery, python-vobject, s3cmd,
  python-prompt-toolkit, ptpython, python-requests-oauthlib, python-stem,
  python-binaryornot, python2-binaryornot, python-nltk, python-pymongo,
  python-schematics, python-url, python2-url, python-freezegun,
  python-glances, python-graphql-core, python-graphql-relay, python-graphene,
  python-nautilus, python-s3transfer): All [inputs] become
  [propagated-inputs].
* gnu/packages/bioinformatics.scm (python-biopython): Likewise.
* gnu/packages/django.scm (pytest-django): Likewise.
* gnu/packages/mail.scm (python-mailmanclient): Likewise.
* gnu/packages/password-utils.scm (python-bcrypt): Likewise.
* gnu/packages/propbuf.scm (python-protobuf): Likewise.
* gnu/packages/rdf.scm (python-rdflib): Likewise.

SQACH all become propagated
---
 gnu/packages/bioinformatics.scm |   2 +-
 gnu/packages/django.scm         |   2 +-
 gnu/packages/mail.scm           |   2 +-
 gnu/packages/password-utils.scm |   2 +-
 gnu/packages/protobuf.scm       |   2 +-
 gnu/packages/python.scm         | 136 ++++++++++++++++++++--------------------
 gnu/packages/rdf.scm            |   2 +-
 7 files changed, 74 insertions(+), 74 deletions(-)

(limited to 'gnu/packages/rdf.scm')

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9872933693..9cfb30023f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -669,7 +669,7 @@ (define-public python-biopython
          (add-before 'check 'set-home
            ;; Some tests require a home directory to be set.
            (lambda _ (setenv "HOME" "/tmp") #t)))))
-    (inputs
+    (propagated-inputs
      `(("python-numpy" ,python-numpy)))
     (home-page "http://biopython.org/")
     (synopsis "Tools for biological computation in Python")
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 804f681e59..2de80353f8 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -141,7 +141,7 @@ (define-public python-pytest-django
     (native-inputs
      `(("python-django" ,python-django)
        ("python-setuptools-scm" ,python-setuptools-scm)))
-    (inputs
+    (propagated-inputs
      `(("python-py" ,python-py)
        ("python-pytest" ,python-pytest)))
     (home-page "http://pytest-django.readthedocs.org/")
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b44555c04d..bb7d16ce27 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1733,7 +1733,7 @@ (define-public python-mailmanclient
     (build-system python-build-system)
     (arguments
      `(#:tests? #f)) ; Requires mailman running
-    (inputs
+    (propagated-inputs
      `(("python-six" ,python-six)
        ("python-httplib2" ,python-httplib2)))
     (home-page "https://launchpad.net/mailman.client")
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 2e3c3b0632..cf030ecc82 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -361,7 +361,7 @@ (define-public python-bcrypt
     (native-inputs
      `(("python-pycparser" ,python-pycparser)
        ("python-pytest" ,python-pytest)))
-    (inputs
+    (propagated-inputs
      `(("python-cffi" ,python-cffi)
        ("python-six" ,python-six)))
     (home-page "https://github.com/pyca/bcrypt/")
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index f4e9e88233..12f6f70521 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -63,7 +63,7 @@ (define-public python-protobuf
         (base32
          "1xbgbfg4g43bihkyw1a2giqa2gxmqc5wkh0fzqcb90qi1z1hpi7c"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-six" ,python-six)))
     (home-page "https://github.com/google/protobuf")
     (synopsis "Protocol buffers is a data interchange format")
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3fcd92dc83..3de73c76a5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -464,7 +464,7 @@ (define-public python-passlib
     (build-system python-build-system)
     (native-inputs
      `(("python-nose" ,python-nose)))
-    (inputs
+    (propagated-inputs
      `(("python-py-bcrypt" ,python-py-bcrypt)))
     (arguments
      `(#:phases
@@ -536,9 +536,8 @@ (define-public python-paramiko
          "14k8z7ndc3zk5xivnm4d8lncchx475ll5izpf8vmfbq7rp9yp5rj"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-pycrypto" ,python-pycrypto)))
-    (inputs
-     `(("python-ecdsa" ,python-ecdsa)))
+     `(("python-pycrypto" ,python-pycrypto)
+       ("python-ecdsa" ,python-ecdsa)))
     (home-page "http://www.paramiko.org/")
     (synopsis "SSHv2 protocol library")
     (description "Paramiko is a python implementation of the SSHv2 protocol,
@@ -617,7 +616,7 @@ (define-public python-ccm
         (base32
          "177dfxsmk3k4cih6fh6v8d91bh4nqx7ns6pc07w7m7i3cvdx3c8n"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-pyyaml" ,python-pyyaml)
        ("python-six" ,python-six)))
     (home-page "https://github.com/pcmanus/ccm")
@@ -665,7 +664,7 @@ (define-public python-babel
        (base32
         "0k43pi0p1dwpds2w0km3fw92wixzxv2vw7p09capxmjz5cfh23lw"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-pytz" ,python-pytz)))
     (arguments `(#:tests? #f)) ; no test target
     (home-page "http://babel.pocoo.org/")
@@ -901,7 +900,7 @@ (define-public python-keyring
     (build-system python-build-system)
     (native-inputs
      `(("python-setuptools-scm" ,python-setuptools-scm)))
-    (inputs
+    (propagated-inputs
      `(("python-pycrypto" ,python-pycrypto)))
     (arguments
      `(#:tests? #f))                      ;TODO: tests require pytest
@@ -954,7 +953,7 @@ (define-public python-dateutil-2
        (base32
         "0jrfpcgvgya6hs45dhrd9yiqgdgz9qp9aa07zsw8gqgn8zphff86"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-six" ,python-six)))
     (home-page "https://dateutil.readthedocs.io/en/stable/")
     (synopsis "Extensions to the standard datetime module")
@@ -1029,9 +1028,8 @@ (define-public python-pandas
         (base32 "1ckpxrvvjj6zxmn68icd9hib8qcpx9b35f6izxnr25br5ilq7r6j"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-numpy" ,python-numpy)))
-    (inputs
-     `(("python-pytz" ,python-pytz)
+     `(("python-numpy" ,python-numpy)
+       ("python-pytz" ,python-pytz)
        ("python-dateutil" ,python-dateutil-2)))
     (native-inputs
      `(("python-nose" ,python-nose)))
@@ -1060,7 +1058,8 @@ (define-public python-tzlocal
        (base32
         "0paj7vlsb0np8b5sp4bv64wxv7qk2piyp7xg29pkhdjwsbls9fnb"))))
     (build-system python-build-system)
-    (inputs `(("python-pytz" ,python-pytz)))
+    (propagated-inputs
+     `(("python-pytz" ,python-pytz)))
     (home-page "https://github.com/regebro/tzlocal")
     (synopsis
      "Local timezone information for Python")
@@ -1289,7 +1288,8 @@ (define-public python2-pybugz
     (arguments
      `(#:python ,python-2                         ; SyntaxError with Python 3
        #:tests? #f))                              ; no 'test' sub-command
-    (inputs `(("element-tree" ,python2-element-tree)))
+    (propagated-inputs
+     `(("element-tree" ,python2-element-tree)))
     (synopsis "Python and command-line interface to Bugzilla")
     (description
      "PyBugz is a Python library and command-line tool to query the Bugzilla
@@ -1339,7 +1339,7 @@ (define-public python-parse-type
        (base32
         "0iv1c34npr4iynwpgv1vkjx9rjd18a85ir8c01gc5f7wp8iv7l1x"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-six" ,python-six)
        ("python-parse" ,python-parse)))
     (arguments '(#:tests? #f))            ;TODO: tests require pytest
@@ -1490,7 +1490,7 @@ (define-public python-nose2
             "1x4zjq1zlyrh8b9ba0cmafd3w94pxhid408kibyjd3s6h1lap6s7"))))
     (build-system python-build-system)
     (arguments `(#:tests? #f)) ; 'module' object has no attribute 'collector'
-    (inputs
+    (propagated-inputs
      `(("python-cov-core" ,python-cov-core)
        ("python-pytest-cov" ,python-pytest-cov)
        ("python-six" ,python-six)))
@@ -1660,7 +1660,7 @@ (define-public python-pytest-cov
          (base32
           "1yl4nbhzfgsxqlsyk4clafgp9x11zvgrkprm9i2p3fgkwx9jxcm8"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-coverage" ,python-coverage)
        ("python-pytest" ,python-pytest)))
     (home-page "https://github.com/pytest-dev/pytest-cov")
@@ -1724,7 +1724,7 @@ (define-public python-pytest-mock
     (build-system python-build-system)
     (native-inputs
      `(("unzip" ,unzip)))
-    (inputs
+    (propagated-inputs
      `(("python-py" ,python-py)
        ("python-pytest" ,python-pytest)))
     (home-page "https://github.com/pytest-dev/pytest-mock/")
@@ -1742,9 +1742,9 @@ (define-public python2-pytest-mock
   (let ((base (package-with-python2
                 (strip-python2-variant python-pytest-mock))))
     (package (inherit base)
-      (inputs
+      (propagated-inputs
        `(("python2-mock" ,python2-mock)
-         ,@(package-inputs base))))))
+         ,@(package-propagated-inputs base))))))
 
 (define-public python-pytest-xdist
   (package
@@ -1769,7 +1769,7 @@ (define-public python-pytest-xdist
     (native-inputs
      `(("unzip" ,unzip)
        ("python-setuptools-scm" ,python-setuptools-scm)))
-    (inputs
+    (propagated-inputs
      `(("python-apipkg" ,python-apipkg)
        ("python-execnet" ,python-execnet)
        ("python-pytest" ,python-pytest)
@@ -1804,7 +1804,7 @@ (define-public python-scripttest
         (base32
          "0f4w84k8ck82syys7yg9maz93mqzc8p5ymis941x034v44jzq74m"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-pytest" ,python-pytest)))
     (home-page "http://pythonpaste.org/scripttest/")
     (synopsis "Python library to test command-line scripts")
@@ -1831,9 +1831,8 @@ (define-public python-testtools
          "1dyml28ykpl5jb9khdmcdvhy1cxqingys6qvj2k04fzlaj6z3bbx"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-mimeparse" ,python-mimeparse)))
-    (inputs
-     `(("python-extras" ,python-extras)))
+     `(("python-mimeparse" ,python-mimeparse)
+       ("python-extras" ,python-extras)))
     (home-page "https://github.com/testing-cabal/testtools")
     (synopsis
      "Extensions to the Python standard library unit testing framework")
@@ -1860,7 +1859,7 @@ (define-public python-testscenarios
         (base32
          "1671jvrvqlmbnc42j7pc5y6vc37q44aiwrq0zic652pxyy2fxvjg"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-testtools" ,python-testtools)
        ("python-mimeparse" ,python-mimeparse)))
     (home-page "https://launchpad.net/testscenarios")
@@ -1912,7 +1911,7 @@ (define-public python-subunit
         (base32
          "1nkw9wfbvizmpajbj3in8ns07g7lwkiv8hip14jjlwk3cacls6jv"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-testtools" ,python-testtools)
        ("python-mimeparse" ,python-mimeparse)
        ("python-testscenarios" ,python-testscenarios)))
@@ -1975,7 +1974,7 @@ (define-public python-pbr-0.11
     (build-system python-build-system)
     (arguments
      `(#:tests? #f)) ;; Most tests seem to use the Internet.
-    (inputs
+    (propagated-inputs
       `(("python-fixtures-0.3.16" ,python-fixtures-0.3.16)))
     (home-page "https://launchpad.net/pbr")
     (synopsis "Change the default behavior of Python’s setuptools")
@@ -2172,7 +2171,7 @@ (define-public behave
               (base32
                "1iypp6z46r19n4xmgx6m1lwmlpfjh8vapq8izigrqlaarvp2y64c"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-six" ,python-six)
        ("python-parse" ,python-parse)
        ("python-parse-type" ,python-parse-type)))
@@ -2486,7 +2485,7 @@ (define-public python-oauthlib
      `(("python-coverage" ,python-coverage)
        ("python-nose" ,python-nose)
        ("python-mock" ,python-mock)))
-    (inputs
+    (propagated-inputs
      `(("python-blinker" ,python-blinker)
        ("python-cryptography" ,python-cryptography)
        ("python-pyjwt" ,python-pyjwt)))
@@ -2628,7 +2627,7 @@ (define-public python-jinja2
         (base32
          "1x0v41lp5m1pjix3l46zx02b7lqp2hflgpnxwkywxynvi3zz47xw"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-markupsafe" ,python-markupsafe)))
     (home-page "http://jinja.pocoo.org/")
     (synopsis "Python template engine")
@@ -2772,7 +2771,7 @@ (define-public python-sphinx
         (base32
          "011xizm3jnmf4cvs5i6kgf6c5nn046h79i8j0vd0f27yw9j3p4wl"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-jinja2" ,python-jinja2)
        ("python-docutils" ,python-docutils)
        ("python-pygments" ,python-pygments)))
@@ -2874,7 +2873,7 @@ (define-public pelican
         (base32
          "1hn94rb4q3zmcq16in055xikal4dba5hfx3zznq7warllcgc9f8k"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-feedgenerator" ,python-feedgenerator)
        ("python-jinja2" ,python-jinja2)
        ("python-pygments" ,python-pygments)
@@ -4293,7 +4292,7 @@ (define-public python-gridmap
        (sha256
         (base32 "1gzjg2k6f14i1msm2b0ax8d9ds1hvk6qd5nlaivg8m4cxqp4cp1x"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-psutil" ,python-psutil)
        ("python-drmaa" ,python-drmaa)
        ("python-pyzmq" ,python-pyzmq)))
@@ -4858,7 +4857,7 @@ (define-public python-urwidtrees
     (build-system python-build-system)
     (arguments
      '(#:tests? #f)) ; no tests
-    (inputs `(("python-urwid" ,python-urwid)))
+    (propagated-inputs `(("python-urwid" ,python-urwid)))
     (home-page "https://github.com/pazz/urwidtrees")
     (synopsis "Tree widgets for urwid")
     (description "Urwidtrees is a Widget Container API for the @code{urwid}
@@ -5322,7 +5321,7 @@ (define-public python-tornado
     (build-system python-build-system)
     (native-inputs
      `(("python-certifi" ,python-certifi)))
-    (inputs
+    (propagated-inputs
      `(("python-backports-abc" ,python-backports-abc)))
     (home-page "http://www.tornadoweb.org/")
     (synopsis "Python web framework and asynchronous networking library")
@@ -5338,11 +5337,11 @@ (define-public python-tornado
 (define-public python2-tornado
   (let ((tornado (package-with-python2 (strip-python2-variant python-tornado))))
     (package (inherit tornado)
-      (inputs
+      (propagated-inputs
        `(("python2-backport-ssl-match-hostname"
           ,python2-backport-ssl-match-hostname)
          ("python2-singledispatch" ,python2-singledispatch)
-          ,@(package-inputs tornado))))))
+          ,@(package-propagated-inputs tornado))))))
 
 ;; the python- version can be removed with python-3.5
 (define-public python-backports-abc
@@ -6560,7 +6559,7 @@ (define-public python-debian
         (base32
          "193faznwnjc3n5991wyzim6h9gyq1zxifmfrnpm3avgkh7ahyynh"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-six" ,python-six)))
     (home-page "http://packages.debian.org/sid/python-debian")
     (synopsis "Debian package related modules")
@@ -7668,7 +7667,7 @@ (define-public python-execnet
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-setuptools-scm" ,python-setuptools-scm)))
-    (inputs
+    (propagated-inputs
      `(("python-apipkg" ,python-apipkg)))
     (synopsis "Rapid multi-Python deployment")
     (description "Execnet provides a share-nothing model with
@@ -7698,7 +7697,7 @@ (define-public python-pytest-cache
               (base32
                "1a873fihw4rhshc722j4h6j7g3nj7xpgsna9hhg3zn6ksknnhx5y"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-apipkg" ,python-apipkg)
        ("python-execnet" ,python-execnet)
        ("python-py" ,python-py)
@@ -7733,7 +7732,7 @@ (define-public python-pytest-localserver
      `(("python-pytest" ,python-pytest)
        ("python-requests" ,python-requests)
        ("python-six" ,python-six)))
-    (inputs
+    (propagated-inputs
      `(("python-werkzeug" ,python-werkzeug)))
     (synopsis "Py.test plugin to test server connections locally")
     (description "Pytest-localserver is a plugin for the pytest testing
@@ -7865,7 +7864,7 @@ (define-public python-clint
                (base32
                 "1an5lkkqk1zha47198p42ji3m94xmzx1a03dn7866m87n4r4q8h5"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-args" ,python-args)))
     (home-page "https://github.com/kennethreitz/clint")
     (synopsis "Command-line interface tools")
@@ -7910,7 +7909,7 @@ (define-public python-rply
                (base32
                 "12rp1d9ba7nvd5rhaxi6xzx1rm67r1k1ylsrkzhpwnphqpb06cvj"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-appdirs" ,python-appdirs)))
     (home-page "https://github.com/alex/rply")
     (synopsis "Parser generator for Python")
@@ -7934,7 +7933,7 @@ (define-public python-hy
                (base32
                 "1msqv747iz12r73mz4qvsmlwkddwjvrahlrk7ysrcz07h7dsscxs"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-astor" ,python-astor)
        ("python-clint" ,python-clint)
        ("python-rply" ,python-rply)))
@@ -7963,7 +7962,7 @@ (define-public python-rauth
     (build-system python-build-system)
     (arguments
      `(#:test-target "check"))
-    (inputs
+    (propagated-inputs
      `(("python-requests" ,python-requests)))
     (home-page "https://github.com/litl/rauth")
     (synopsis "Python library for OAuth 1.0/a, 2.0, and Ofly")
@@ -8127,7 +8126,7 @@ (define-public python-rsa
       (base32
        "1dcxvszbikgzh99ybdc7jq0zb9wspy2ds8z9mjsqiyv3q884xpr5"))))
    (build-system python-build-system)
-   (inputs
+   (propagated-inputs
     `(("python-pyasn1" ,python-pyasn1)))
    (synopsis "Pure-Python RSA implementation")
    (description "Python-RSA is a pure-Python RSA implementation.  It supports
@@ -8828,7 +8827,7 @@ (define-public python-celery
                (system* "nosetests" "--exclude=^test_safe_to_remove.*")))))))
     (native-inputs
      `(("python-nose" ,python-nose)))
-    (inputs
+    (propagated-inputs
      `(("python-pytz" ,python-pytz)
        ("python-amqp" ,python-amqp)
        ("python-anyjson" ,python-anyjson)
@@ -8994,7 +8993,7 @@ (define-public python-vobject
     (arguments
      '(;; The test suite relies on some non-portable Windows interfaces.
        #:tests? #f))
-    (inputs
+    (propagated-inputs
      `(("python-dateutil-2" ,python-dateutil-2)
        ("python-pyicu" ,python-pyicu)))
     (synopsis "Parse and generate vCard and vCalendar files")
@@ -9384,7 +9383,7 @@ (define-public python2-s3cmd
      ;; s3cmd is written for python2 only and contains no tests.
      `(#:python ,python-2
        #:tests? #f))
-    (inputs
+    (propagated-inputs
      `(("python2-dateutil" ,python2-dateutil)
        ;; The python-file package also provides a magic.py module.
        ;; This is an unfortunate state of affairs; however, s3cmd
@@ -10339,8 +10338,9 @@ (define-public python-prompt-toolkit
   (build-system python-build-system)
   (arguments
    '(#:tests? #f)) ; The test suite uses some Windows-specific data types.
-  (inputs `(("python-wcwidth" ,python-wcwidth)
-            ("python-pygments" ,python-pygments)))
+  (propagated-inputs
+   `(("python-wcwidth" ,python-wcwidth)
+     ("python-pygments" ,python-pygments)))
   (native-inputs `(("python-six" ,python-six)))
   (home-page "https://github.com/jonathanslenders/python-prompt-toolkit")
   (synopsis "Library for building command line interfaces in Python")
@@ -10388,7 +10388,7 @@ (define-public ptpython
                (base32
                 "1mmbiyzf0n8hm7z2a562x7w5cbl6jc0zsk6vp40q1z4cyblv1k13"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-docopt" ,python-docopt)
        ("python-jedi" ,python-jedi)
        ("python-prompt-toolkit" ,python-prompt-toolkit)
@@ -10432,7 +10432,7 @@ (define-public python-requests-oauthlib
     (native-inputs
      `(("python-requests-mock" ,python-requests-mock)
        ("python-mock" ,python-mock)))
-    (inputs
+    (propagated-inputs
      `(("python-oauthlib" ,python-oauthlib)
        ("python-requests" ,python-requests)))
     (home-page
@@ -10469,7 +10469,7 @@ (define-public python-stem
      `(("python-mock" ,python-mock)
        ("python-pep8" ,python-pep8)
        ("python-pyflakes" ,python-pyflakes)))
-    (inputs
+    (propagated-inputs
      `(("python-pycrypto" ,python-pycrypto)))
     (home-page "https://stem.torproject.org/")
     (synopsis
@@ -10581,7 +10581,7 @@ (define-public python-binaryornot
                (base32
                 "1j4f51dxic39mdwf6alj7gd769wy6mhk916v031wjali51xkh3xb"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-chardet" ,python-chardet)
        ("python-hypothesis" ,python-hypothesis)))
     (home-page "https://github.com/audreyr/binaryornot")
@@ -10594,9 +10594,9 @@ (define-public python-binaryornot
 (define-public python2-binaryornot
   (let ((base (package-with-python2 (strip-python2-variant python-binaryornot))))
     (package (inherit base)
-      (inputs
+      (propagated-inputs
        `(("python2-enum34" ,python2-enum34)
-         ,@(package-inputs base))))))
+         ,@(package-propagated-inputs base))))))
 
 (define-public python-nltk
   (package
@@ -10635,7 +10635,7 @@ (define-public python-pymongo
                (base32
                 "07mra6w86wjqy4lx5fvimidjhhfzd562gfjn8grsnbv2q8pk0i9x"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-certifi" ,python-certifi)))
     (home-page "http://github.com/mongodb/mongo-python-driver")
     (synopsis "Python driver for MongoDB")
@@ -10707,7 +10707,7 @@ (define-public python-schematics
          (base32
           "19v1i69bf3bzarfxmbv0v6ivpcn758x3shvbiy9l2hy0lvqwnp6l"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-six" ,python-six)))
     (arguments
      `(#:tests? #f)) ; requires a bunch of not very nice packages with fixed
@@ -10776,7 +10776,7 @@ (define-public python-url
                (base32
                 "0v879yadcz9qxfl41ak6wkga1kimp9cflla9ddz03hjjvgkqy5ki"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-publicsuffix" ,python-publicsuffix)))
     (native-inputs
      `(("python-coverage" ,python-coverage)
@@ -10792,7 +10792,7 @@ (define-public python-url
 (define-public python2-url
   (let ((base (package-with-python2 (strip-python2-variant python-url))))
     (package (inherit base)
-      (inputs
+      (propagated-inputs
        `(("python2-publicsuffix" ,python2-publicsuffix))))))
 
 (define-public python-freezegun
@@ -10812,7 +10812,7 @@ (define-public python-freezegun
        ("python-nose" ,python-nose)
        ("python-coverage" ,python-coverage)
        ("python-dateutil-2" ,python-dateutil-2)))
-    (inputs
+    (propagated-inputs
      `(("python-six" ,python-six)))
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -11052,7 +11052,7 @@ (define-public python-glances
         (base32
           "11jbq40g8alsbirnd4kiagznqg270247i0m8qhi48ldf2i5xppxg"))))
   (build-system python-build-system)
-  (inputs
+  (propagated-inputs
    `(("python-psutil" ,python-psutil)))
   (home-page
     "https://github.com/nicolargo/glances")
@@ -11092,7 +11092,7 @@ (define-public python-graphql-core
      `(("python-gevent" ,python-gevent)
        ("python-mock" ,python-mock)
        ("python-pytest-mock" ,python-pytest-mock)))
-    (inputs
+    (propagated-inputs
      `(("python-promise" ,python-promise)
        ("python-six" ,python-six)))
     (home-page "https://github.com/graphql-python/graphql-core")
@@ -11121,7 +11121,7 @@ (define-public python-graphql-relay
     (build-system python-build-system)
     (native-inputs
      `(("python-pytest" ,python-pytest)))
-    (inputs
+    (propagated-inputs
      `(("python-graphql-core" ,python-graphql-core)
        ("python-promise" ,python-promise)
        ("python-six" ,python-six)))
@@ -11156,7 +11156,7 @@ (define-public python-graphene
        ("python-psycopg2" ,python-psycopg2)
        ("python-pytest-django" ,python-pytest-django)
        ("python-sqlalchemy-utils" ,python-sqlalchemy-utils)))
-    (inputs
+    (propagated-inputs
      `(("python-graphql-core" ,python-graphql-core)
        ("python-graphql-relay" ,python-graphql-relay)
        ("python-iso8601" ,python-iso8601)
@@ -11192,7 +11192,7 @@ (define-public python-nautilus
           "01hwzjc1zshk4vvxrcghm398fpy4jls66dyz06g07mrwqif8878p"))))
     (build-system python-build-system)
     (arguments `(#:tests? #f)) ; fails to import test modules
-    (inputs
+    (propagated-inputs
      `(("python-bcrypt" ,python-bcrypt)
        ("python-click" ,python-click)
        ("python-consul" ,python-consul)
@@ -11264,7 +11264,7 @@ (define-public python-s3transfer
      `(("python-docutils" ,python-docutils)
        ("python-mock" ,python-mock)
        ("python-nose" ,python-nose)))
-    (inputs
+    (propagated-inputs
      `(("python-botocore" ,python-botocore)))
     (synopsis "Amazon S3 Transfer Manager")
     (description "S3transfer is a Python library for managing Amazon S3
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 1a8d13369b..1dd23c28e3 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -315,7 +315,7 @@ (define-public python-rdflib
           (base32
             "0kvaf332cqbi47rqzlpdx4mbkvw12mkrzkj8n9l19wk713d4py9w"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
       `(("python-html5lib" ,python-html5lib)
         ("python-isodate" ,python-isodate)
         ("python-pyparsing" ,python-pyparsing)))
-- 
cgit v1.2.3