From a156b3d2f72933ec69b56277313ea2919f44f2f1 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 20 Jul 2024 20:45:01 +0100
Subject: gnu: Add packages/prometheus module.

* gnu/packages/prometheus.scm: New file.
* gnu/local.mk: Add gnu/packages/prometheus.scm to the scope.

Change-Id: Ie291afe3b4470c1681d3d77e62ffe2ee090d3a54
---
 gnu/packages/prometheus.scm | 46 +++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
 create mode 100644 gnu/packages/prometheus.scm

(limited to 'gnu/packages/prometheus.scm')

diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
new file mode 100644
index 0000000000..e898602ea0
--- /dev/null
+++ b/gnu/packages/prometheus.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages prometheus)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system go)
+  #:use-module (guix gexp)
+  #:use-module (guix git-download)
+  #:use-module (guix packages)
+  #:use-module (gnu packages))
+
+;;; Commentary:
+;;;
+;;; Libraries and commands related to, or provided by Prometheus project
+;;; <https://prometheus.io>.
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+;;; Code:
+
+;;;
+;;; Libraries:
+;;;
+
+;;;
+;;; Executables:
+;;;
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above in alphabetic order.
+;;;
-- 
cgit v1.2.3