From ebd181138ea850c76103acb1fba3c84c3ba42ef8 Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Sun, 27 Aug 2017 15:01:16 +0200
Subject: gnu: perl: Work around more "dotless @INC" build failures.

* gnu/packages/perl.scm (perl-unicode-collate)[arguments]: Add
'set-perl-search-path' phase.
* gnu/packages/xorg.scm (perl-x11-xcb)[arguments]: Likewise.
---
 gnu/packages/perl.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

(limited to 'gnu/packages/perl.scm')

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1a96ee237b..93fc4059d8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8165,6 +8165,16 @@ (define-public perl-unicode-collate
         (base32
          "1lq4p3mqqljhhy8wyiyahris33j4m5qfzpi6iacmcqjzw5g4afbm"))))
     (build-system perl-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'set-perl-search-path
+           (lambda _
+             ;; Work around "dotless @INC" build failure.
+             (setenv "PERL5LIB"
+                     (string-append (getcwd) ":"
+                                    (getenv "PERL5LIB")))
+             #t)))))
     (propagated-inputs
      `(("perl-unicode-normalize" ,perl-unicode-normalize)))
     (home-page "http://search.cpan.org/dist/Unicode-Collate")
-- 
cgit v1.2.3


From 02654c47b2439bc42be744ac6c9a53b6c593d6f6 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Tue, 29 Aug 2017 20:15:46 +0100
Subject: gnu: Escape @ in the perl-importer package description.

@EXPORT is interpreted as a texinfo command, therefore the @ needs
escaping. This was causing a test failure in the guix-package.sh file.

* gnu/packages/perl.scm (perl-importer)[description]: Escape @.
---
 gnu/packages/perl.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'gnu/packages/perl.scm')

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 93fc4059d8..3967ef8b7d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3514,7 +3514,7 @@ (define-public perl-importer
 consume exports.  It is feature-compatible with Exporter, plus some much needed
 extras.  You can use this to import symbols from any exporter that follows
 Exporters specification.  The exporter modules themselves do not need to use or
-inherit from the Exporter module, they just need to set @EXPORT and/or other
+inherit from the Exporter module, they just need to set @@EXPORT and/or other
 variables.")
     (license (package-license perl))))
 
-- 
cgit v1.2.3


From def056d13842f7cd799970844f79d071c6b82739 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 1 Sep 2017 20:48:13 +0200
Subject: gnu: perl-context-preserve: Update source URL.

* gnu/packages/perl.scm (perl-context-preserve)[source]: Update CPAN author.
---
 gnu/packages/perl.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'gnu/packages/perl.scm')

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3967ef8b7d..249f478f96 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1295,7 +1295,7 @@ (define-public perl-context-preserve
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://cpan/authors/id/J/JR/JROCKWAY/"
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
                            "Context-Preserve-" version ".tar.gz"))
        (sha256
         (base32
-- 
cgit v1.2.3