From 18ffd2f9687a7c8af0041c129c47db31b7e810c3 Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludo@gnu.org>
Date: Fri, 10 Apr 2020 14:48:02 +0200
Subject: gnu: binutils: Shorten file names of MinGW patches.

This ensures we stay below the POSIX tar file name length limit.

* gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch:
Rename to...
* gnu/packages/patches/binutils-mingw-w64-deterministic.patch: ... this.
* gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch:
Rename to...
* gnu/packages/patches/binutils-mingw-w64-timestamp.patch: ... this.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/cross-base.scm (cross-binutils): Likewise.
---
 .../patches/binutils-mingw-w64-deterministic.patch |  22 ++++
 ...s-mingw-w64-reproducible-import-libraries.patch |  22 ----
 .../binutils-mingw-w64-specify-timestamp.patch     | 137 ---------------------
 .../patches/binutils-mingw-w64-timestamp.patch     | 137 +++++++++++++++++++++
 4 files changed, 159 insertions(+), 159 deletions(-)
 create mode 100644 gnu/packages/patches/binutils-mingw-w64-deterministic.patch
 delete mode 100644 gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
 delete mode 100644 gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch
 create mode 100644 gnu/packages/patches/binutils-mingw-w64-timestamp.patch

(limited to 'gnu/packages/patches')

diff --git a/gnu/packages/patches/binutils-mingw-w64-deterministic.patch b/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
new file mode 100644
index 0000000000..3e48b87935
--- /dev/null
+++ b/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
@@ -0,0 +1,22 @@
+This following patch was originally found at the debian mingw-w64 team's
+binutils repo located here:
+https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+  $ git show da63f6b:debian/patches/reproducible-import-libraries.patch
+
+Description: Make DLL import libraries reproducible
+Author: Benjamin Moody <benjamin.moody@gmail.com>
+Bug-Debian: https://bugs.debian.org/915055
+
+--- a/ld/pe-dll.c
++++ b/ld/pe-dll.c
+@@ -2844,6 +2844,7 @@
+ 
+   bfd_set_format (outarch, bfd_archive);
+   outarch->has_armap = 1;
++  outarch->flags |= BFD_DETERMINISTIC_OUTPUT;
+ 
+   /* Work out a reasonable size of things to put onto one line.  */
+   ar_head = make_head (outarch);
diff --git a/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch b/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
deleted file mode 100644
index 3e48b87935..0000000000
--- a/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-This following patch was originally found at the debian mingw-w64 team's
-binutils repo located here:
-https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
-
-Invoke the following in the aforementioned repo to see the original patch:
-
-  $ git show da63f6b:debian/patches/reproducible-import-libraries.patch
-
-Description: Make DLL import libraries reproducible
-Author: Benjamin Moody <benjamin.moody@gmail.com>
-Bug-Debian: https://bugs.debian.org/915055
-
---- a/ld/pe-dll.c
-+++ b/ld/pe-dll.c
-@@ -2844,6 +2844,7 @@
- 
-   bfd_set_format (outarch, bfd_archive);
-   outarch->has_armap = 1;
-+  outarch->flags |= BFD_DETERMINISTIC_OUTPUT;
- 
-   /* Work out a reasonable size of things to put onto one line.  */
-   ar_head = make_head (outarch);
diff --git a/gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch b/gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch
deleted file mode 100644
index b785043b62..0000000000
--- a/gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch
+++ /dev/null
@@ -1,137 +0,0 @@
-This following patch was originally found at the debian mingw-w64 team's
-binutils repo located here:
-https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
-
-Invoke the following in the aforementioned repo to see the original patch:
-
-  $ git show da63f6b:debian/patches/specify-timestamp.patch
-
-Description: Allow the PE timestamp to be specified
-Author: Stephen Kitt <skitt@debian.org>
-
---- a/bfd/peXXigen.c
-+++ b/bfd/peXXigen.c
-@@ -70,6 +70,9 @@
- #include <wctype.h>
- #endif
- 
-+#include <errno.h>
-+#include <limits.h>
-+
- /* NOTE: it's strange to be including an architecture specific header
-    in what's supposed to be general (to PE/PEI) code.  However, that's
-    where the definitions are, and they don't vary per architecture
-@@ -879,10 +882,38 @@
- 
-   /* Use a real timestamp by default, unless the no-insert-timestamp
-      option was chosen.  */
--  if ((pe_data (abfd)->insert_timestamp))
--    H_PUT_32 (abfd, time (0), filehdr_out->f_timdat);
--  else
-+  if (pe_data (abfd)->insert_timestamp) {
-+    time_t now;
-+    char *source_date_epoch;
-+    unsigned long long epoch;
-+    char *endptr;
-+
-+    now = time(NULL);
-+    source_date_epoch = getenv("SOURCE_DATE_EPOCH");
-+    if (source_date_epoch) {
-+      errno = 0;
-+      epoch = strtoull(source_date_epoch, &endptr, 10);
-+      if ((errno == ERANGE && (epoch == ULLONG_MAX || epoch == 0))
-+          || (errno != 0 && epoch == 0)) {
-+        _bfd_error_handler("Environment variable $SOURCE_DATE_EPOCH: strtoull: %s\n",
-+                           strerror(errno));
-+      } else if (endptr == source_date_epoch) {
-+        _bfd_error_handler("Environment variable $SOURCE_DATE_EPOCH: No digits were found: %s\n",
-+                           endptr);
-+      } else if (*endptr != '\0') {
-+        _bfd_error_handler("Environment variable $SOURCE_DATE_EPOCH: Trailing garbage: %s\n",
-+                           endptr);
-+      } else if (epoch > ULONG_MAX) {
-+        _bfd_error_handler("Environment variable $SOURCE_DATE_EPOCH: value must be smaller than or equal to: %lu but was found to be: %llu\n",
-+                           ULONG_MAX, epoch);
-+      } else {
-+        now = epoch;
-+      }
-+    }
-+    H_PUT_32 (abfd, now, filehdr_out->f_timdat);
-+  } else {
-     H_PUT_32 (abfd, 0, filehdr_out->f_timdat);
-+  }
- 
-   PUT_FILEHDR_SYMPTR (abfd, filehdr_in->f_symptr,
- 		      filehdr_out->f_symptr);
---- a/ld/pe-dll.c
-+++ b/ld/pe-dll.c
-@@ -26,6 +26,8 @@
- #include "filenames.h"
- #include "safe-ctype.h"
- 
-+#include <errno.h>
-+#include <limits.h>
- #include <time.h>
- 
- #include "ld.h"
-@@ -1202,8 +1204,36 @@
- 
-   memset (edata_d, 0, edata_sz);
- 
--  if (pe_data (abfd)->insert_timestamp)
--    H_PUT_32 (abfd, time (0), edata_d + 4);
-+  if (pe_data (abfd)->insert_timestamp) {
-+    time_t now;
-+    char *source_date_epoch;
-+    unsigned long long epoch;
-+    char *endptr;
-+
-+    now = time(NULL);
-+    source_date_epoch = getenv("SOURCE_DATE_EPOCH");
-+    if (source_date_epoch) {
-+      errno = 0;
-+      epoch = strtoull(source_date_epoch, &endptr, 10);
-+      if ((errno == ERANGE && (epoch == ULLONG_MAX || epoch == 0))
-+	  || (errno != 0 && epoch == 0)) {
-+	einfo("Environment variable $SOURCE_DATE_EPOCH: strtoull: %s\n",
-+	      strerror(errno));
-+      } else if (endptr == source_date_epoch) {
-+	einfo("Environment variable $SOURCE_DATE_EPOCH: No digits were found: %s\n",
-+	      endptr);
-+      } else if (*endptr != '\0') {
-+	einfo("Environment variable $SOURCE_DATE_EPOCH: Trailing garbage: %s\n",
-+	      endptr);
-+      } else if (epoch > ULONG_MAX) {
-+	einfo("Environment variable $SOURCE_DATE_EPOCH: value must be smaller than or equal to: %lu but was found to be: %llu\n",
-+	      ULONG_MAX, epoch);
-+      } else {
-+	now = epoch;
-+      }
-+    }
-+    H_PUT_32 (abfd, now, edata_d + 4);
-+  }
- 
-   if (pe_def_file->version_major != -1)
-     {
---- a/ld/emultempl/pe.em
-+++ b/ld/emultempl/pe.em
-@@ -303,7 +303,7 @@
-      OPTION_USE_NUL_PREFIXED_IMPORT_TABLES},
-     {"no-leading-underscore", no_argument, NULL, OPTION_NO_LEADING_UNDERSCORE},
-     {"leading-underscore", no_argument, NULL, OPTION_LEADING_UNDERSCORE},
--    {"insert-timestamp", no_argument, NULL, OPTION_INSERT_TIMESTAMP},
-+    {"insert-timestamp", optional_argument, NULL, OPTION_INSERT_TIMESTAMP},
-     {"no-insert-timestamp", no_argument, NULL, OPTION_NO_INSERT_TIMESTAMP},
- #ifdef DLL_SUPPORT
-     /* getopt allows abbreviations, so we do this to stop it
---- a/ld/emultempl/pep.em
-+++ b/ld/emultempl/pep.em
-@@ -321,7 +321,7 @@
-     {"no-bind", no_argument, NULL, OPTION_NO_BIND},
-     {"wdmdriver", no_argument, NULL, OPTION_WDM_DRIVER},
-     {"tsaware", no_argument, NULL, OPTION_TERMINAL_SERVER_AWARE},
--    {"insert-timestamp", no_argument, NULL, OPTION_INSERT_TIMESTAMP},
-+    {"insert-timestamp", optional_argument, NULL, OPTION_INSERT_TIMESTAMP},
-     {"no-insert-timestamp", no_argument, NULL, OPTION_NO_INSERT_TIMESTAMP},
-     {"build-id", optional_argument, NULL, OPTION_BUILD_ID},
-     {NULL, no_argument, NULL, 0}
diff --git a/gnu/packages/patches/binutils-mingw-w64-timestamp.patch b/gnu/packages/patches/binutils-mingw-w64-timestamp.patch
new file mode 100644
index 0000000000..b785043b62
--- /dev/null
+++ b/gnu/packages/patches/binutils-mingw-w64-timestamp.patch
@@ -0,0 +1,137 @@
+This following patch was originally found at the debian mingw-w64 team's
+binutils repo located here:
+https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+  $ git show da63f6b:debian/patches/specify-timestamp.patch
+
+Description: Allow the PE timestamp to be specified
+Author: Stephen Kitt <skitt@debian.org>
+
+--- a/bfd/peXXigen.c
++++ b/bfd/peXXigen.c
+@@ -70,6 +70,9 @@
+ #include <wctype.h>
+ #endif
+ 
++#include <errno.h>
++#include <limits.h>
++
+ /* NOTE: it's strange to be including an architecture specific header
+    in what's supposed to be general (to PE/PEI) code.  However, that's
+    where the definitions are, and they don't vary per architecture
+@@ -879,10 +882,38 @@
+ 
+   /* Use a real timestamp by default, unless the no-insert-timestamp
+      option was chosen.  */
+-  if ((pe_data (abfd)->insert_timestamp))
+-    H_PUT_32 (abfd, time (0), filehdr_out->f_timdat);
+-  else
++  if (pe_data (abfd)->insert_timestamp) {
++    time_t now;
++    char *source_date_epoch;
++    unsigned long long epoch;
++    char *endptr;
++
++    now = time(NULL);
++    source_date_epoch = getenv("SOURCE_DATE_EPOCH");
++    if (source_date_epoch) {
++      errno = 0;
++      epoch = strtoull(source_date_epoch, &endptr, 10);
++      if ((errno == ERANGE && (epoch == ULLONG_MAX || epoch == 0))
++          || (errno != 0 && epoch == 0)) {
++        _bfd_error_handler("Environment variable $SOURCE_DATE_EPOCH: strtoull: %s\n",
++                           strerror(errno));
++      } else if (endptr == source_date_epoch) {
++        _bfd_error_handler("Environment variable $SOURCE_DATE_EPOCH: No digits were found: %s\n",
++                           endptr);
++      } else if (*endptr != '\0') {
++        _bfd_error_handler("Environment variable $SOURCE_DATE_EPOCH: Trailing garbage: %s\n",
++                           endptr);
++      } else if (epoch > ULONG_MAX) {
++        _bfd_error_handler("Environment variable $SOURCE_DATE_EPOCH: value must be smaller than or equal to: %lu but was found to be: %llu\n",
++                           ULONG_MAX, epoch);
++      } else {
++        now = epoch;
++      }
++    }
++    H_PUT_32 (abfd, now, filehdr_out->f_timdat);
++  } else {
+     H_PUT_32 (abfd, 0, filehdr_out->f_timdat);
++  }
+ 
+   PUT_FILEHDR_SYMPTR (abfd, filehdr_in->f_symptr,
+ 		      filehdr_out->f_symptr);
+--- a/ld/pe-dll.c
++++ b/ld/pe-dll.c
+@@ -26,6 +26,8 @@
+ #include "filenames.h"
+ #include "safe-ctype.h"
+ 
++#include <errno.h>
++#include <limits.h>
+ #include <time.h>
+ 
+ #include "ld.h"
+@@ -1202,8 +1204,36 @@
+ 
+   memset (edata_d, 0, edata_sz);
+ 
+-  if (pe_data (abfd)->insert_timestamp)
+-    H_PUT_32 (abfd, time (0), edata_d + 4);
++  if (pe_data (abfd)->insert_timestamp) {
++    time_t now;
++    char *source_date_epoch;
++    unsigned long long epoch;
++    char *endptr;
++
++    now = time(NULL);
++    source_date_epoch = getenv("SOURCE_DATE_EPOCH");
++    if (source_date_epoch) {
++      errno = 0;
++      epoch = strtoull(source_date_epoch, &endptr, 10);
++      if ((errno == ERANGE && (epoch == ULLONG_MAX || epoch == 0))
++	  || (errno != 0 && epoch == 0)) {
++	einfo("Environment variable $SOURCE_DATE_EPOCH: strtoull: %s\n",
++	      strerror(errno));
++      } else if (endptr == source_date_epoch) {
++	einfo("Environment variable $SOURCE_DATE_EPOCH: No digits were found: %s\n",
++	      endptr);
++      } else if (*endptr != '\0') {
++	einfo("Environment variable $SOURCE_DATE_EPOCH: Trailing garbage: %s\n",
++	      endptr);
++      } else if (epoch > ULONG_MAX) {
++	einfo("Environment variable $SOURCE_DATE_EPOCH: value must be smaller than or equal to: %lu but was found to be: %llu\n",
++	      ULONG_MAX, epoch);
++      } else {
++	now = epoch;
++      }
++    }
++    H_PUT_32 (abfd, now, edata_d + 4);
++  }
+ 
+   if (pe_def_file->version_major != -1)
+     {
+--- a/ld/emultempl/pe.em
++++ b/ld/emultempl/pe.em
+@@ -303,7 +303,7 @@
+      OPTION_USE_NUL_PREFIXED_IMPORT_TABLES},
+     {"no-leading-underscore", no_argument, NULL, OPTION_NO_LEADING_UNDERSCORE},
+     {"leading-underscore", no_argument, NULL, OPTION_LEADING_UNDERSCORE},
+-    {"insert-timestamp", no_argument, NULL, OPTION_INSERT_TIMESTAMP},
++    {"insert-timestamp", optional_argument, NULL, OPTION_INSERT_TIMESTAMP},
+     {"no-insert-timestamp", no_argument, NULL, OPTION_NO_INSERT_TIMESTAMP},
+ #ifdef DLL_SUPPORT
+     /* getopt allows abbreviations, so we do this to stop it
+--- a/ld/emultempl/pep.em
++++ b/ld/emultempl/pep.em
+@@ -321,7 +321,7 @@
+     {"no-bind", no_argument, NULL, OPTION_NO_BIND},
+     {"wdmdriver", no_argument, NULL, OPTION_WDM_DRIVER},
+     {"tsaware", no_argument, NULL, OPTION_TERMINAL_SERVER_AWARE},
+-    {"insert-timestamp", no_argument, NULL, OPTION_INSERT_TIMESTAMP},
++    {"insert-timestamp", optional_argument, NULL, OPTION_INSERT_TIMESTAMP},
+     {"no-insert-timestamp", no_argument, NULL, OPTION_NO_INSERT_TIMESTAMP},
+     {"build-id", optional_argument, NULL, OPTION_BUILD_ID},
+     {NULL, no_argument, NULL, 0}
-- 
cgit v1.2.3