From 5c51cdb962966b55b055460489f3ef9d539648e2 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
Date: Wed, 15 Aug 2018 11:28:47 +0200
Subject: gnu: ghc-uuid: Allow building with newer HUnit.

* gnu/packages/haskell.scm (ghc-uuid)[arguments]: Allow newer HUnit.
---
 gnu/packages/haskell.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'gnu/packages/haskell.scm')

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 63b671f88f..d4a2ec0b61 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8731,7 +8731,8 @@ functions.")
          "09xhk42yhxvqmka0iqrv3338asncz8cap3j0ic0ps896f2581b6z"))))
     (build-system haskell-build-system)
     (arguments
-     `(#:configure-flags (list "--allow-newer=QuickCheck")))
+     `(#:configure-flags (list "--allow-newer=QuickCheck"
+                               "--allow-newer=HUnit")))
     (inputs `(("ghc-cryptohash-sha1" ,ghc-cryptohash-sha1)
               ("ghc-cryptohash-md5" ,ghc-cryptohash-md5)
               ("ghc-entropy" ,ghc-entropy)
-- 
cgit v1.2.3