From e58d01faf5780db0efa54f0b40f63acd18e1b30c Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
Date: Thu, 12 Feb 2015 11:58:40 +0100
Subject: gnu: hisat: fix build on non-x86_64.

* gnu/packages/bioinformatics.scm (hisat): Add "POPCNT_CAPABILITY=0" to
  make-flags on architectures other than x86_64.
---
 gnu/packages/bioinformatics.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1766855c93..75837923e2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -197,8 +197,15 @@ Illumina, Roche 454, and the SOLiD platform.")
                 "1k381ydranqxp09yf2y7w1d0chz5d59vb6jchi89hbb0prq19lk5"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ;no check target
-       #:make-flags '("allall")
+     `(#:tests? #f ;no check target
+       #:make-flags '("allall"
+                      ;; Disable unsupported `popcnt' instructions on
+                      ;; architectures other than x86_64
+                      ,@(if (string-prefix? "x86_64"
+                                            (or (%current-target-system)
+                                                (%current-system)))
+                            '()
+                            '("POPCNT_CAPABILITY=0")))
        #:phases
        (alist-replace
         'unpack
-- 
cgit v1.2.3