From cb723be5b98a57ae4f909022d1ce2b5d3bcdaabf Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Mon, 26 Feb 2018 05:03:22 +0100
Subject: gnu: python-scandir: Run the test suite.

* gnu/packages/python.scm (python-scandir)[arguments]: Replace CHECK-PHASE.
---
 gnu/packages/python.scm | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 64f48fd352..4946d9afd7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11091,6 +11091,11 @@ It supports both normal and Unicode strings.")
        (sha256
         (base32 "0gbnhjzg42rj87ljv9kb648rfxph69ly3c8r9841dxy4d7l5pmdj"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "python" "test/run_tests.py"))))))
     (home-page "https://github.com/benhoyt/scandir")
     (synopsis "Directory iteration function")
     (description
-- 
cgit v1.2.3