From ba5324c30e4102b34c8859e2e013392455273562 Mon Sep 17 00:00:00 2001
From: John Darrington <jmd@gnu.org>
Date: Thu, 28 Aug 2014 18:20:13 +0200
Subject: gnu: Add perl-archive-zip.

* gnu/packages/perl.scm (perl-archive-zip): New variable.
---
 gnu/packages/perl.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 48b543436e..164f6bd099 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -121,3 +121,23 @@ matching a regular expression.")
      "This package provides the 'IO::Pty' and 'IO::Tty' Perl interfaces to
 pseudo ttys.")
     (license (package-license perl))))
+
+(define-public perl-archive-zip
+  (package
+    (name "perl-archive-zip")
+    (version "1.30")
+    (source 
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/A/AD/ADAMK/Archive-Zip-" 
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0633zah5z9njiqnvy3vh42fjymncmil1jdfb7d18w8xpfzzp5d7q"))))
+    (build-system perl-build-system)
+    (synopsis "Perl API to zip files")
+    (description "The Archive::Zip module allows a Perl program to create,
+manipulate, read, and write Zip archive files.")
+    (home-page "http://search.cpan.org/~phred/Archive-Zip-1.37/lib/Archive/Zip.pm")
+    (license (package-license perl))))
-- 
cgit v1.2.3