From 6fd2ecedb6e3ed802580561cd98a925a68292182 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@gnu.org>
Date: Tue, 28 Jul 2020 23:30:05 -0500
Subject: gnu: emacs-erc-image: Patch eval-after-load procedure.

* gnu/packages/emacs-xyz.scm (emacs-erc-image)[arguments]: Create a phase that
substitutes the ERC module for ERC-AUTO. When ERC is used the autoloader for
for Emacs hangs indefinitely (if daemonized) or fails.
---
 gnu/packages/emacs-xyz.scm | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 44f8c44233..5dc0bc9fa0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14179,7 +14179,7 @@ arXiv, Google Scholar, Library of Congress, etc.
 
 (define-public emacs-erc-image
   (let ((commit "82fb3871f02e24b1e880770b9a3d187aab43d0f0")
-        (revision "1"))
+        (revision "2"))
     (package
       (name "emacs-erc-image")
       (version (git-version "0" revision commit))
@@ -14194,6 +14194,17 @@ arXiv, Google Scholar, Library of Congress, etc.
           (base32
            "1q8mkf612fb4fjp8h4kbr107wn083iqfdgv8f80pcmil8y33dw9i"))))
       (build-system emacs-build-system)
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    ;; NOTE: The autoloader for Guix will fail
+                    ;; because this package asserts an incorrect
+                    ;; `eval-after-load'.
+                    (add-after 'unpack 'patch-autoload-generation
+                      (lambda _
+                        (substitute* "erc-image.el"
+                          (("eval-after-load 'erc")
+                           "eval-after-load 'erc-auto"))
+                        #t)))))
       (home-page "https://github.com/kidd/erc-image.el")
       (synopsis "Show inlined images (png/jpg/gif/svg) in ERC buffers")
       (description "This plugin subscribes to hooks @code{erc-insert-modify-hook}
-- 
cgit v1.2.3