From 57a31efb4b2690f8198c751f01a8091ba5f9d0a3 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Mon, 26 Sep 2016 03:00:01 +0200
Subject: gnu: tcc: Disable build on MIPS.

* gnu/packages/c.scm (tcc)[supported-systems]: Disable build on
mips64el.
---
 gnu/packages/c.scm | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 6e16d1365b..4b9791348e 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -58,6 +59,8 @@
                                               (assoc-ref %build-inputs "libc")
                                               "/lib"))
        #:test-target "test"))
+    ;; Fails to build on MIPS: "Unsupported CPU"
+    (supported-systems (delete "mips64el-linux" %supported-systems))
     (synopsis "Tiny and fast C compiler")
     (description
      "TCC, also referred to as \"TinyCC\", is a small and fast C compiler
-- 
cgit v1.2.3