From 3cbf1204ef733881916c4667f05c7a7968bb658d Mon Sep 17 00:00:00 2001
From: Eric Bavier <bavier@member.fsf.org>
Date: Mon, 5 Oct 2015 22:16:40 -0500
Subject: gnu: imagemagick: Hard-code delegate paths.

If --with-frozenpaths is given, then configure will retain absolute paths
discovered for delegate programs, otherwise they are discarded.

* gnu/packages/imagemagick.scm (imagemagick)[arguments]: Add
  '--with-frozenpaths' to #:configure-flags.
---
 gnu/packages/imagemagick.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 8e176845e1..f154e19d35 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -49,7 +49,8 @@
              (patches (list (search-patch "imagemagick-test-segv.patch")))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
+     `(#:configure-flags '("--with-frozenpaths")
+       #:phases (modify-phases %standard-phases
                   (add-before
                    'build 'pre-build
                    (lambda* (#:key outputs #:allow-other-keys)
-- 
cgit v1.2.3