From 0084f0054f1b8f8a778ced6622775a1a9c3e50d3 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Fri, 30 Apr 2021 09:49:46 -0400
Subject: build: Correct a mistake in the guix-manual.pot rule.

This is a follow-up to commit 0d353b06ec.

* po/doc/local.mk: Fix function name in comment.
(%D%/guix-manual.pot): Refer to *all* the prerequisites via the $^ special
variable rather than $<, which only refers to the first one.

Reported-by: Julien Lepiller <julien@lepiller.eu>
---
 po/doc/local.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/po/doc/local.mk b/po/doc/local.mk
index da43c0a314..4458774efe 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -47,7 +47,7 @@ POT_OPTIONS = \
 	--copyright-holder "the authors of Guix (msgids)" 		\
 	--msgid-bugs-address "bug-guix@gnu.org"
 
-# make-download-po-files-rule PO_FILES POT_FILE_INPUT
+# make-update-po-files-rule PO_FILES POT_FILE_INPUT
 define make-update-po-files-rule
 $(1): $(2)
 	@if ! [ -f "$$@" ]; then \
@@ -67,7 +67,7 @@ endef
 	touch $@
 
 %D%/guix-manual.pot: %D%/guix.pot %D%/contributing.pot
-	msgcat $< > $@
+	msgcat $^ > $@
 
 $(eval $(call make-update-po-files-rule,$(DOC_PO_FILES),%D%/guix-manual.pot))
 $(eval $(call make-update-po-files-rule,\
-- 
cgit v1.2.3