aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 52ac86dfbd..e4316831d0 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -633,9 +633,20 @@ to run without any changes.")
(arguments
(list #:configure-flags
#~(list (string-append "--with-ssl="
- #$(this-package-input "openssl")))))
+ #$(this-package-input "openssl")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-fetchmailconf
+ (lambda _
+ (wrap-program (string-append #$output "/bin/fetchmailconf")
+ `("GUIX_PYTHONPATH" ":"
+ prefix (,(getenv "GUIX_PYTHONPATH")))))))))
(inputs
- (list openssl))
+ (list openssl
+ ;; Needed for fetchmailconf
+ bash-minimal
+ python-future
+ python-wrapper))
(home-page "https://www.fetchmail.info/")
(synopsis "Remote-mail retrieval and forwarding utility")
(description