aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm187
1 files changed, 98 insertions, 89 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d586bd0815..fc6caf3ff8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
-;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
@@ -890,12 +890,14 @@ audio/video codec library.")
(name "ffmpegthumbnailer")
(version "2.2.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/dirkvdb/"
- name "/archive/" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dirkvdb/ffmpegthumbnailer.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "13qs4iwd4l3iiim30s5051n80z0vgsnikym8vsn321cnm9algiwb"))))
+ "0kl8aa547icy9b05njps02a8sw4yn4f8fzs228kig247sn09s4cp"))))
(build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -1187,14 +1189,14 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(name "mpv")
(version "0.29.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mpv-player/mpv/archive/v" version
- ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mpv-player/mpv.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "08x63hlpj6s8xixmdbx6raff5p5mih7cnk0bcql9f3wrs5hx9ygr"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "138921kx8g6qprim558xin09xximjhsj9ss8b71ifg2m6kclym8m"))))
(build-system waf-build-system)
(native-inputs
`(("perl" ,perl) ; for zsh completion file
@@ -1457,14 +1459,14 @@ other site that youtube-dl supports.")
(name "you-get")
(version "0.4.1077")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/soimort/you-get/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/soimort/you-get.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "04vxc91k627qgsqs8dhqajrb6vpj4pw21jlwbha28qakfiz2x11k"))))
+ "1rwkn3wb3r70b8cqj40qdknkg9kqbgzkvi901hbpy2a8s1b7858n"))))
(build-system python-build-system)
(inputs
`(("ffmpeg" ,ffmpeg))) ; for multi-part and >=1080p videos
@@ -1856,14 +1858,14 @@ capabilities.")
(name "vapoursynth")
(version "37")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/vapoursynth/vapoursynth/archive/R"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vapoursynth/vapoursynth.git")
+ (commit (string-append "R" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1g3hc079jw4mz1cmkv2y28pdb556wqc8ql7iravgh1rg8j3f1zi5"))))
+ "1ma2s7dxk6y6l04qj1jvgwia4xj7999ny3a1yx2vbk5l83giam2p"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2008,13 +2010,14 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(name "mlt")
(version "6.10.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mltframework/mlt/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mltframework/mlt.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1zzdj1g3g24q6v8hd0v34lv0pkh37a13fhjpl44h1ffi00mz3577"))
+ "0ki86yslr5ywa6sz8pjrgd9a4rn2rr4mss2zkmqi7pq8prgsm1fr"))
(modules '((guix build utils)))
(snippet '(begin
;; As of glibc 2.26, <xlocale.h> no longer is.
@@ -2107,13 +2110,14 @@ be used for realtime video capture via Linux-specific APIs.")
(name "obs")
(version "20.1.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/jp9000/obs-studio"
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jp9000/obs-studio.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1g5z6z050v25whc7n3xvg6l238wmg5crp7ihvk73qngvzxr8bg28"))))
+ "0qdpa2xxiiw53ksvlrf80jm8gz6kxsn56sffv2v2ijxvy7kw5zcg"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; no tests
@@ -2269,13 +2273,14 @@ making @dfn{screencasts}.")
(version "0.3.11")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/MaartenBaert/ssr/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MaartenBaert/ssr.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0l6irdadqpajvv0dj3ngs1231n559l0y1pykhs2h7526qm4w7xal"))))
+ "0n702dnv4qshgn3b90ixvplfafjhgz6040yir5vy8khjdpciysq4"))))
(build-system cmake-build-system)
;; Although libx11, libxfixes, libxext are listed as build dependencies in
;; README.md, the program builds and functions properly without them.
@@ -2393,13 +2398,14 @@ Content System specification.")
(version "0.2.8")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/mps-youtube/mps-youtube/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mps-youtube/mps-youtube.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0x7cmfh199q9j396v7bz81nnvanfllhsg86489i5dw2p3yyc9wnm"))))
+ "1w1jhw9rg3dx7vp97cwrk5fymipkcy2wrbl1jaa38ivcjhqg596y"))))
(build-system python-build-system)
(arguments
;; Tests need to be disabled until #556 upstream is fixed. It reads as if the
@@ -2424,22 +2430,27 @@ supported players in addition to this package.")
(define-public handbrake
(package
(name "handbrake")
- (version "0.10.5")
+ (version "1.1.2")
(source (origin
(method url-fetch)
- (uri (string-append "https://handbrake.fr/rotation.php?file="
- "HandBrake-" version ".tar.bz2"))
- (file-name (string-append "handbrake-" version ".tar.bz2"))
+ (uri (string-append "https://download.handbrake.fr/releases/"
+ version "/HandBrake-" version "-source.tar.bz2"))
(sha256
(base32
- "1w720y3bplkz187wgvy4a4xm0vpppg45mlni55l6yi8v2bfk14pv"))
- (patches (search-patches "handbrake-pkg-config-path.patch"))
+ "0bny0hwlr55g2c69rsamv0xvwmfh1s4a582b9vq20xv5ly84m6ms"))
(modules '((guix build utils)))
(snippet
- ;; Remove bundled libraries and source not necessary for
- ;; running under a GNU environment.
+ ;; Remove "contrib" and source not necessary for
+ ;; building/running under a GNU environment.
'(begin
- (for-each delete-file-recursively '("contrib" "macosx" "win"))
+ (for-each delete-file-recursively
+ '("contrib" "macosx" "win"))
+ (substitute* "make/include/main.defs"
+ ;; Disable unconditional inclusion of "contrib" libraries
+ ;; (ffmpeg, libvpx, libdvdread, libdvdnav, and libbluray),
+ ;; which would lead to fetching and building of these
+ ;; libraries. Use our own instead.
+ (("MODULES \\+= contrib") "# MODULES += contrib"))
#t))))
(build-system glib-or-gtk-build-system)
(native-inputs
@@ -2453,13 +2464,14 @@ supported players in addition to this package.")
(inputs
`(("bzip2" ,bzip2)
("dbus-glib" ,dbus-glib)
- ("ffmpeg" ,ffmpeg-3.4) ;compilation errors with ffmpeg-4
+ ("ffmpeg" ,ffmpeg)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("glib" ,glib)
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+)
+ ("jansson" ,jansson)
("lame" ,lame)
("libass" ,libass)
("libbluray" ,libbluray)
@@ -2469,6 +2481,7 @@ supported players in addition to this package.")
("libmpeg2" ,libmpeg2)
("libnotify" ,libnotify)
("libogg" ,libogg)
+ ("libopus" ,opus)
("libsamplerate" ,libsamplerate)
("libtheora" ,libtheora)
("libvorbis" ,libvorbis)
@@ -2479,6 +2492,11 @@ supported players in addition to this package.")
("zlib" ,zlib)))
(arguments
`(#:tests? #f ;tests require Ruby and claim to be unsupported
+ #:configure-flags
+ (list (string-append "CPPFLAGS=-I"
+ (assoc-ref %build-inputs "libxml2")
+ "/include/libxml2")
+ "LDFLAGS=-lx265")
#:phases
(modify-phases %standard-phases
(replace 'bootstrap
@@ -2490,21 +2508,6 @@ supported players in addition to this package.")
(substitute* "gtk/module.rules"
((".*autogen\\.sh.*") ""))
(invoke "sh" "./gtk/autogen.sh")))
- (add-before 'configure 'disable-contrib
- (lambda _
- (substitute* "make/include/main.defs"
- ;; Disable unconditional inclusion of some "contrib"
- ;; libraries (ffmpeg, libvpx, libdvdread, libdvdnav,
- ;; and libbluray), which would lead to fetching and
- ;; building of these libraries. Use our own instead.
- (("MODULES \\+= contrib") "# MODULES += contrib"))
- #t))
- (add-before 'configure 'fix-x265-linking
- (lambda _
- (substitute* "test/module.defs"
- ;; Fix missing library during linking error
- (("TEST.GCC.l =") "TEST.GCC.l = x265"))
- #t))
(replace 'configure
(lambda* (#:key outputs configure-flags #:allow-other-keys)
;; 'configure' is not an autoconf-generated script, and
@@ -2521,8 +2524,9 @@ supported players in addition to this package.")
(description
"HandBrake is a tool for converting video from any format to a selection
of modern, widely supported codecs.")
- ;; Most under GPL version 2 or later, and portions under BSD 3 Clause
- (license (list license:gpl2+ license:bsd-3))))
+ ;; Some under GPLv2+, some under LGPLv2.1+, and portions under BSD3.
+ ;; Combination under GPLv2. See LICENSE.
+ (license license:gpl2)))
(define-public openh264
(package
@@ -2787,12 +2791,14 @@ and ITU-T H.222.0.")
(version "2.23")
(home-page "https://github.com/FFMS/ffms2")
(source (origin
- (method url-fetch)
- (uri (string-append home-page "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FFMS/ffms2.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1vbkab8vrplxz5xgag8ggzkwp4f7nf285pd0l2a7zy66n6i2m6xh"))))
+ "0dkz5b3gxq5p4xz0qqg6l2sigszrlsinz3skyf0ln4wf3zrvf8m5"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -2876,13 +2882,14 @@ tools for styling them, including a built-in real-time video preview.")
(version "1.12.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/pitivi/gst-transcoder/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pitivi/gst-transcoder.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0cnwmrsd321s02ff91m3j27ydj7f8wks0jvmp5admlhka6z7zxm9"))))
+ "0nw1zykqc6c8xs3ri55pm00pwyz93z4y4nd880apfiwj7yv5p3az"))))
(build-system meson-build-system)
(inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -3068,14 +3075,14 @@ save it to the appropriate filename.")
(name "l-smash")
(version "2.14.5")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/" name "/" name "/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/l-smash/l-smash.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0dary0h65kq6sv93iabv25djlvzr5ckdcp3ywagbix44wqfw7xz6"))))
+ "0rcq9727im6kd8da8b7kzzbzxdldvmh5nsljj9pvr4m3lj484b02"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no tests
@@ -3130,12 +3137,14 @@ online.")
(name "vidstab")
(version "1.1.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/georgmartius/vid.stab/"
- "archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/georgmartius/vid.stab.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1fy03n343djfdi19msac81833v5iivpv635yjzrx9nkfwm9s1lhl"))))
+ "0a3frpm2kdbx7vszhg64p3alisag73bcspl7fp3a2f1kgq7rbh38"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; tests are not run as part of standard build process