aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 679aa46d60..91796efd0f 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -85,7 +85,18 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; and can use statically-linked NSS modules.
`(cons* "--disable-nscd" "--disable-build-nscd"
"--enable-static-nss"
- ,flags))))
+ ,flags))
+ ((#:phases phases #~%standard-phases)
+ ;; Apply i686-linux-specific patch.
+ (if (target-x86-32?)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'apply-libm-patch
+ (lambda _
+ (define patch
+ #$(local-file
+ (search-patch "glibc-2.39-fmod-libm-a.patch")))
+ (invoke "patch" "--force" "-p1" "-i" patch))))
+ phases))))
;; Remove the 'debug' output to allow bit-reproducible builds (when the
;; 'debug' output is used, ELF files end up with a .gnu_debuglink, which