aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-web.scm26
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 70397c311f..5c1ece7389 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -959,6 +959,32 @@ for Go.")
"This package provides a SASL library written in Go.")
(license license:expat))))
+(define-public go-github-com-emersion-go-smtp
+ (package
+ (name "go-github-com-emersion-go-smtp")
+ (version "0.21.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-smtp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0drvmvrkmhqhnv4m3my1hbkyyva2vi35b36j0pdi57xc9rflziq3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-smtp"))
+ (propagated-inputs
+ (list go-github-com-emersion-go-sasl))
+ (home-page "https://github.com/emersion/go-smtp")
+ (synopsis "SMTP implementation for Go")
+ (description
+ "This package implements the Simple Mail Transfer Protocol as defined by
+RFC 5321.")
+ (license license:expat)))
+
(define-public go-github-com-emicklei-go-restful
(package
(name "go-github-com-emicklei-go-restful")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 15a7954a58..ec5a1421d0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5595,30 +5595,6 @@ a cron spec parser and job runner.")
"This is a fork of another go-libvterm library for use with aerc.")
(license license:expat))))
-(define-public go-github-com-emersion-go-smtp
- (package
- (name "go-github-com-emersion-go-smtp")
- (version "0.21.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emersion/go-smtp")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0drvmvrkmhqhnv4m3my1hbkyyva2vi35b36j0pdi57xc9rflziq3"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/emersion/go-smtp"))
- (propagated-inputs (list go-github-com-emersion-go-sasl))
- (home-page "https://github.com/emersion/go-smtp")
- (synopsis "SMTP implementation for Go")
- (description
- "This package implements the Simple Mail Transfer Protocol as
-defined by RFC 5321.")
- (license license:expat)))
-
(define-public go-github-com-google-uuid
(package
(name "go-github-com-google-uuid")