aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-web.scm28
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 28 insertions, 26 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index d4b4c4043f..e0a83a03c7 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2633,6 +2633,34 @@ router.")
@acronym{Simple Service Discovery Protocol, SSDP}} library for Golang.")
(license license:expat)))
+(define-public go-github-com-libp2p-go-flow-metrics
+ (package
+ (name "go-github-com-libp2p-go-flow-metrics")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-flow-metrics")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13yb68vrcn2zdi0mjjh17dphfxl6y99bkq0ia53hasyfj6l6626h"))))
+ (build-system go-build-system)
+ (arguments
+ ;; XXX: Tests may hang sometimes, see
+ ;; <https://github.com/libp2p/go-flow-metrics/issues/30>.
+ (list
+ #:import-path "github.com/libp2p/go-flow-metrics"))
+ (propagated-inputs
+ (list go-github-com-benbjohnson-clock))
+ (home-page "https://github.com/libp2p/go-flow-metrics")
+ (synopsis "Simple library for tracking flow metrics")
+ (description
+ "A simple alternative to rcrowley's @command{go-metrics} that's a lot
+faster (and only does simple bandwidth metrics).")
+ (license license:expat)))
+
(define-public go-github-com-libp2p-go-nat
(package
(name "go-github-com-libp2p-go-nat")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70b183f996..26fdde6abf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4290,32 +4290,6 @@ generation features. This code generation is used to achieve:
(home-page "https://github.com/gogo/protobuf")
(license license:bsd-3)))
-(define-public go-github-com-libp2p-go-flow-metrics
- (package
- (name "go-github-com-libp2p-go-flow-metrics")
- (version "0.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/libp2p/go-flow-metrics")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "13yb68vrcn2zdi0mjjh17dphfxl6y99bkq0ia53hasyfj6l6626h"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/libp2p/go-flow-metrics"))
- (propagated-inputs
- (list go-github-com-benbjohnson-clock))
- (home-page
- "https://github.com/libp2p/go-flow-metrics")
- (synopsis "Simple library for tracking flow metrics")
- (description "A simple alternative to rcrowley's @command{go-metrics}
-that's a lot faster (and only does simple bandwidth metrics).")
- (license license:expat)))
-
(define-public go-github-com-btcsuite-btclog
(let ((commit "84c8d2346e9fc8c7b947e243b9c24e6df9fd206a")
(revision "0"))