summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 945260c..61f5d0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,11 +8,13 @@ AM_SILENT_RULES([yes]) # enables silent rules by default
AC_CANONICAL_HOST
-# Prepare a version of $localstatedir that does not contain references to
-# shell variables.
+# Prepare a version of installation directories that does not contain
+# references to shell variables.
expanded_prefix="`eval echo $prefix | sed -e "s|NONE|/usr/local|g"`"
-expanded_localstatedir="`eval echo $localstatedir | sed -e "s|NONE|$expanded_prefix|g"`"
-AC_SUBST([expanded_localstatedir])
+AC_SUBST([expanded_datadir],
+ [`eval echo $datadir | sed -e "s|NONE|$expanded_prefix|g"`])
+AC_SUBST([expanded_localstatedir],
+ [`eval echo $localstatedir | sed -e "s|NONE|$expanded_prefix|g"`])
PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.7])
AC_PATH_PROG([GUILE], [guile])