summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am3
-rw-r--r--tests/utils.scm39
2 files changed, 41 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d2d4821..aa822ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,8 @@ SCM_LOG_DRIVER = \
TESTS = \
tests/base.scm \
- tests/database.scm
+ tests/database.scm \
+ tests/utils.scm
# Unset 'GUILE_LOAD_COMPILED_PATH' altogether while compiling. Otherwise, if
# $GUILE_LOAD_COMPILED_PATH contains $(cuirassmoduledir), we may find .go
diff --git a/tests/utils.scm b/tests/utils.scm
new file mode 100644
index 0000000..4b9d767
--- /dev/null
+++ b/tests/utils.scm
@@ -0,0 +1,39 @@
+;;;; utils.scm -- tests for (cuirass utils) module
+;;;
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+;;;
+;;; This file is part of Cuirass.
+;;;
+;;; Cuirass is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Cuirass is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
+
+(use-modules (cuirass utils)
+ (srfi srfi-64))
+
+(define dir-1 (make-parameter ""))
+(define dir-2 (make-parameter ""))
+
+(test-assert "with-directory-excursion"
+ (let ((old (getcwd))
+ (tmp (tmpnam)))
+ (dynamic-wind
+ (λ ()
+ (mkdir tmp))
+ (λ ()
+ (with-directory-excursion tmp
+ (dir-1 (getcwd)))
+ (dir-2 (getcwd))
+ (and (string=? (dir-1) tmp)
+ (string=? (dir-2) old)))
+ (λ ()
+ (rmdir tmp)))))