summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--bin/cuirass.in1
-rw-r--r--src/cuirass/database.scm1
-rw-r--r--src/cuirass/job.scm77
-rw-r--r--tests/database.scm1
5 files changed, 0 insertions, 81 deletions
diff --git a/Makefile.am b/Makefile.am
index aa01e88..f178cf7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,6 @@ noinst_SCRIPTS = pre-inst-env
dist_pkgmodule_DATA = \
src/cuirass/base.scm \
src/cuirass/database.scm \
- src/cuirass/job.scm \
src/cuirass/ui.scm \
src/cuirass/utils.scm
diff --git a/bin/cuirass.in b/bin/cuirass.in
index 8b3f05d..e38449a 100644
--- a/bin/cuirass.in
+++ b/bin/cuirass.in
@@ -24,7 +24,6 @@ exec ${GUILE:-@GUILE@} --no-auto-compile -e main -s "$0" "$@"
(use-modules (cuirass config)
(cuirass base)
(cuirass database)
- (cuirass job)
(cuirass ui)
(cuirass utils)
(guix derivations)
diff --git a/src/cuirass/database.scm b/src/cuirass/database.scm
index 505ef4c..88e282c 100644
--- a/src/cuirass/database.scm
+++ b/src/cuirass/database.scm
@@ -20,7 +20,6 @@
(define-module (cuirass database)
#:use-module (cuirass base)
#:use-module (cuirass config)
- #:use-module (cuirass job)
#:use-module (sqlite3)
#:export (;; Procedures.
db-init
diff --git a/src/cuirass/job.scm b/src/cuirass/job.scm
deleted file mode 100644
index b6f92c9..0000000
--- a/src/cuirass/job.scm
+++ /dev/null
@@ -1,77 +0,0 @@
-;;;; job.scm - data structures for jobs
-;;;
-;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;;
-;;; This file is part of Cuirass.
-;;;
-;;; Cuirass is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; Cuirass is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (cuirass job)
- #:use-module (cuirass base)
- #:use-module (srfi srfi-9)
- #:export (<job>
- make-job
- job?
- job-name
- job-derivation
- job-metadata
-
- <job-spec>
- make-job-spec
- job-spec?
- job-spec-name
- job-spec-url
- job-spec-load-path
- job-spec-branch
- job-spec-commit
- job-spec-tag
- job-spec-file
- job-spec-proc
- job-spec-arguments))
-
-(define-record-type <job>
- (%make-job name derivation metadata)
- job?
- (name job-name) ;string
- (derivation job-derivation) ;string
- (metadata job-metadata)) ;alist
-
-(define-syntax make-job
- (syntax-rules ()
- ;; XXX: Different orders for keyword/argument pairs should be allowed.
- ((make-job #:name name #:derivation filename #:metadata metadata)
- (begin
- (format (current-error-port) "evaluating '~a'... " name)
- (force-output (current-error-port))
- (%make-job name
- (call-with-time-display (λ () filename))
- metadata)))))
-
-(define-record-type <job-spec>
- (%make-job-spec name url load-path branch commit file proc arguments)
- job-spec?
- (name job-spec-name) ;string
- (url job-spec-url) ;string
- (load-path job-spec-load-path) ;string
- (branch job-spec-branch) ;string
- (commit job-spec-commit) ;string
- (tag job-spec-tag) ;string
- (file job-spec-file) ;string
- (proc job-spec-proc) ;symbol
- (arguments job-spec-arguments)) ;alist
-
-(define* (make-job-spec #:key name url load-path
- commit tag file proc arguments
- (branch "master"))
- (%make-job-spec name url load-path branch tag file proc arguments))
diff --git a/tests/database.scm b/tests/database.scm
index 869d73c..eb75363 100644
--- a/tests/database.scm
+++ b/tests/database.scm
@@ -18,7 +18,6 @@
;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
(use-modules (cuirass database)
- (cuirass job)
(srfi srfi-64))
(define* (make-dummy-job #:optional (name "foo"))