summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-07-26 11:25:20 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-07-27 14:16:57 +0200
commitf97b24c29edcea53cd9d3a349711d50e81339034 (patch)
tree30127ae7a704a6337f6f0a67aff49387868e89f2 /tests
parentb8d8c99bd35222174c70dcfbf9a5ea05814f4141 (diff)
downloadcuirass-f97b24c29edcea53cd9d3a349711d50e81339034.tar
cuirass-f97b24c29edcea53cd9d3a349711d50e81339034.tar.gz
tests: Add 'hello-singleton' specification example.
* tests/hello-singleton.scm: New file. * Makefile.am (EXTRA_DIST): Add it.
Diffstat (limited to 'tests')
-rw-r--r--tests/hello-singleton.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/hello-singleton.scm b/tests/hello-singleton.scm
new file mode 100644
index 0000000..5ff2e82
--- /dev/null
+++ b/tests/hello-singleton.scm
@@ -0,0 +1,33 @@
+;;; hello-singleton.scm -- job specification test for hello in master
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+;;;
+;;; This file is part of Cuirass.
+;;;
+;;; Cuirass is free software: you can redistribute it and/or modify
+;;; it under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation, either version 3 of the License, or
+;;; (at your option) any later version.
+;;;
+;;; Cuirass is distributed in the hope that it will be useful,
+;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
+
+(define (local-file file)
+ ;; In the common case jobs will be defined relative to the repository.
+ ;; However for testing purpose use local gnu-system.scm instead.
+ (string-append (dirname (current-filename)) "/" file))
+
+(define hello-master
+ `((#:name . "guix")
+ (#:url . "git://git.savannah.gnu.org/guix.git")
+ (#:load-path . ".")
+ (#:file . ,(local-file "gnu-system.scm"))
+ (#:proc . hydra-jobs)
+ (#:arguments (subset . "hello"))
+ (#:branch . "master")))
+
+(list hello-master)