summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-07-30 23:00:41 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-07-31 01:07:00 +0200
commit651b8bbcf96376b723921820de82061ccdba9c4f (patch)
treedb2976470ec61605273f3c91a066254d04a3df4d /tests
parente58911de37f600dffce3c562ff1d26809343d420 (diff)
downloadcuirass-651b8bbcf96376b723921820de82061ccdba9c4f.tar
cuirass-651b8bbcf96376b723921820de82061ccdba9c4f.tar.gz
Add (cuirass http) module.
* src/cuirass/http.scm: New file. * tests/http.scm: Likewise. * Makefile.am (dist_pkgmodule_DATA, TESTS): Add them. * configure.ac: Check for (json) module.
Diffstat (limited to 'tests')
-rw-r--r--tests/http.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/http.scm b/tests/http.scm
new file mode 100644
index 0000000..09601a9
--- /dev/null
+++ b/tests/http.scm
@@ -0,0 +1,33 @@
+;;; http.scm -- tests for (cuirass http) module
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+;;;
+;;; This file is part of Cuirass.
+;;;
+;;; Cuirass is free software: you can redistribute it and/or modify
+;;; it under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation, either version 3 of the License, or
+;;; (at your option) any later version.
+;;;
+;;; Cuirass is distributed in the hope that it will be useful,
+;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
+
+(use-modules (cuirass http)
+ (srfi srfi-64))
+
+(test-begin "http")
+
+(test-equal "spec->json-string"
+ "{\"boolean\" : false,\"string\" : \"guix\",\"alist\" : {\"subset\" : \"hello\"},\"list\" : [1, \"2\", \"three\"],\"symbol\" : \"hydra-jobs\",\"number\" : 1}"
+ (spec->json-string '((#:number . 1)
+ (string . "guix")
+ ("symbol" . hydra-jobs)
+ (#:alist (subset . "hello"))
+ (list 1 "2" #:three)
+ ("boolean" . #f))))
+
+(test-end)