summaryrefslogtreecommitdiff
path: root/tests/hello-subset.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-12-16 13:20:49 +0100
committerMathieu Lirzin <mthl@gnu.org>2016-12-16 13:20:49 +0100
commite9e1ce8e14ffdbd8ddddaacc93e0e71d0c29a992 (patch)
tree856b9a457bc63667efbfb6f962be957fdd2f79ae /tests/hello-subset.scm
parent5dc1bf40e96ee40f9e786ffeafc3eb895b4e8e74 (diff)
downloadcuirass-e9e1ce8e14ffdbd8ddddaacc93e0e71d0c29a992.tar
cuirass-e9e1ce8e14ffdbd8ddddaacc93e0e71d0c29a992.tar.gz
maint: Move examples from 'tests' to 'examples' directory.
* examples/gnu-system.scm: Moved from 'tests' directory. * examples/guix-jobs.scm: Likewise. * examples/guix-track-git.scm: Likewise. * examples/hello-git.scm: Likewise. * examples/hello-singleton.scm: Likewise. * examples/hello-subset.scm: Likewise. * Makefile.am (EXTRA_DIST): Adapt. * README <Example>: Likewise.
Diffstat (limited to 'tests/hello-subset.scm')
-rw-r--r--tests/hello-subset.scm43
1 files changed, 0 insertions, 43 deletions
diff --git a/tests/hello-subset.scm b/tests/hello-subset.scm
deleted file mode 100644
index 60764fc..0000000
--- a/tests/hello-subset.scm
+++ /dev/null
@@ -1,43 +0,0 @@
-;;; hello-subset.scm -- job specification test for hello subset
-;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;;
-;;; This file is part of Cuirass.
-;;;
-;;; Cuirass is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; Cuirass is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
-
-(define (local-file file)
- ;; In the common case jobs will be defined relative to the repository.
- ;; However for testing purpose use local gnu-system.scm instead.
- (string-append (dirname (current-filename)) "/" file))
-
-(define job-base
- `((#:name . "guix")
- (#:url . "git://git.savannah.gnu.org/guix.git")
- (#:load-path . ".")
- (#:file . ,(local-file "gnu-system.scm"))
- (#:proc . hydra-jobs)
- (#:arguments (subset . "hello"))))
-
-(define guix-master
- (acons #:branch "master" job-base))
-
-(define guix-core-updates
- (acons #:branch "core-updates" job-base))
-
-(define guix-0.10
- (acons #:tag "v0.10.0" job-base))
-
-(list guix-master
- guix-core-updates
- guix-0.10)