summaryrefslogtreecommitdiff
path: root/src/cuirass
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-06-10 23:33:16 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-06-10 23:39:27 +0200
commitecffeb75360134139092cd9d78d2f9387f0124e6 (patch)
treef19fd578717d58646addd9a6191c53f3058333db /src/cuirass
parentd3487acc4286c7cc36547b3329dabd8749a0dd35 (diff)
downloadcuirass-ecffeb75360134139092cd9d78d2f9387f0124e6.tar
cuirass-ecffeb75360134139092cd9d78d2f9387f0124e6.tar.gz
job: Add <job> record type.
* src/cuirass/job.scm: New file. * Makefile.am (dist_pkgmodule_DATA): Add it. * bin/cuirass.in (evaluate, build-packages): Use it.
Diffstat (limited to 'src/cuirass')
-rw-r--r--src/cuirass/job.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/cuirass/job.scm b/src/cuirass/job.scm
new file mode 100644
index 0000000..4efba9e
--- /dev/null
+++ b/src/cuirass/job.scm
@@ -0,0 +1,32 @@
+;;;; job.scm - data structures for jobs
+;;;
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+;;;
+;;; This file is part of Cuirass.
+;;;
+;;; Cuirass is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Cuirass is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (cuirass job)
+ #:use-module (srfi srfi-9)
+ #:export (<job>
+ make-job
+ job?
+ job-name
+ job-derivation))
+
+(define-record-type <job>
+ (make-job name derivation)
+ job?
+ (name job-name) ;string
+ (derivation job-derivation)) ;string