summaryrefslogtreecommitdiff
path: root/src/cuirass/ui.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-06-10 22:27:41 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-06-10 23:39:01 +0200
commit87a79ae33d82b69133aa011da41afbf3d1f9e98d (patch)
tree6cf54d56d5da4ad6ba77667d69d5c7d703ffa75a /src/cuirass/ui.scm
parent8fb2983dcee4fec94bcc78ca4bc0f33eb5560665 (diff)
downloadcuirass-87a79ae33d82b69133aa011da41afbf3d1f9e98d.tar
cuirass-87a79ae33d82b69133aa011da41afbf3d1f9e98d.tar.gz
cuirass: Add command line options.
* bin/cuirass.in (show-help, %options): new variables. (main): Adapt. * src/cuirass/ui.scm: New file. * Makefile.am (dist_pkgmodule_DATA): Add it.
Diffstat (limited to 'src/cuirass/ui.scm')
-rw-r--r--src/cuirass/ui.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/cuirass/ui.scm b/src/cuirass/ui.scm
new file mode 100644
index 0000000..d953f8a
--- /dev/null
+++ b/src/cuirass/ui.scm
@@ -0,0 +1,39 @@
+;;;; ui.scm - user interface facilities for command-line tools
+;;;
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+;;;
+;;; This file is part of Cuirass.
+;;;
+;;; Cuirass is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Cuirass is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (cuirass ui)
+ #:use-module (cuirass config)
+ #:export (show-version
+ show-package-information))
+
+(define (show-version prog)
+ "Display version information for COMMAND."
+ (simple-format #t "~a (~a) ~a~%" prog %package-name %package-version)
+ (display "Copyright (C) 2016 the Cuirass authors
+License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
+This is free software: you are free to change and redistribute it.
+There is NO WARRANTY, to the extent permitted by law.")
+ (newline))
+
+(define (show-package-information)
+ (newline)
+ (format #t "Report bugs to: ~a." %package-bugreport)
+ (newline)
+ (display "General help using GNU software: <http://www.gnu.org/gethelp/>")
+ (newline))