summaryrefslogtreecommitdiff
path: root/src/cuirass/config.scm.in
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-06-10 18:17:53 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-06-10 23:38:40 +0200
commit8fb2983dcee4fec94bcc78ca4bc0f33eb5560665 (patch)
treead83ddb69214d252d5a59a520219a81fdd8c23ca /src/cuirass/config.scm.in
parent9d5fda76bbe7edd954d2a5112f453b9a6f625cf1 (diff)
downloadcuirass-8fb2983dcee4fec94bcc78ca4bc0f33eb5560665.tar
cuirass-8fb2983dcee4fec94bcc78ca4bc0f33eb5560665.tar.gz
build: Generate config.scm at configure time.
* src/cuirass/config.scm.in: New file. * configure.ac (AC_CONFIG_FILES): Add 'src/cuirass/config.scm'. * Makefile.am (nodist_pkgmodule_DATA, CLEANFILES, DISTCLEANFILES): Update. * .gitignore: Likewise.
Diffstat (limited to 'src/cuirass/config.scm.in')
-rw-r--r--src/cuirass/config.scm.in48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/cuirass/config.scm.in b/src/cuirass/config.scm.in
new file mode 100644
index 0000000..ef1b56b
--- /dev/null
+++ b/src/cuirass/config.scm.in
@@ -0,0 +1,48 @@
+;;;; config.scm - variables defined at configure time
+;;;
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+;;;
+;;; This file is part of Cuirass.
+;;;
+;;; Cuirass is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Cuirass is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (cuirass config))
+
+(define-public %package
+ ;; Name of package
+ "@PACKAGE@")
+
+(define-public %package-bugreport
+ ;; Define to the address where bug reports for this package should be sent.
+ "@PACKAGE_BUGREPORT@")
+
+(define-public %package-name
+ ;; Define to the full name of this package.
+ "@PACKAGE_NAME@")
+
+(define-public %package-string
+ ;; Define to the full name and version of this package.
+ "@PACKAGE_STRING@")
+
+(define-public %package-tarname
+ ;; Define to the one symbol short name of this package.
+ "@PACKAGE_TARNAME@")
+
+(define-public %package-url
+ ;; Define to the home page for this package.
+ "@PACKAGE_URL@")
+
+(define-public %package-version
+ ;; Define to the version of this package.
+ "@PACKAGE_VERSION@")